Closed Bug 826723 Opened 7 years ago Closed 7 years ago

Don't ask/give Google Suggestions in Private Browsing mode

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 + verified
firefox21 + verified
relnote-firefox --- -
fennec 20+ ---

People

(Reporter: gcp, Assigned: bnicholson)

References

Details

Attachments

(1 file)

Reported by a user:

When using Private Browsing on a fresh installation, it's possible to get asked if you want to enable Google Suggestions, while in a private tab (issue 1).

When answering yes, you do actually get Google suggestions (issue 2).

Both of those sound unexpected/unwanted to me. mfinkle checked Chrome and they actually disable Google in private mode. Based on this, putting severity as major.
tracking-fennec: --- → ?
Assignee: nobody → bnicholson
tracking-fennec: ? → 20+
The only time Tabs.getInstance().getSelectedTab() should be null is when we're restoring after a crash. We should never restore private tabs when that happens, so it should be safe to assume that null means non-private.
Attachment #700808 - Flags: review?(mark.finkle)
Attachment #700808 - Flags: review?(mark.finkle) → review+
(In reply to Brian Nicholson (:bnicholson) from comment #1)

> The only time Tabs.getInstance().getSelectedTab() should be null is when
> we're restoring after a crash. We should never restore private tabs when
> that happens, so it should be safe to assume that null means non-private.

It might be nice to add a comment to Tabs.getSelectedTab with this information. It could come in handy.
Comment on attachment 700808 [details] [diff] [review]
Don't show suggestions or prompt in private tabs

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: search suggestions will appear in private browsing mode
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #700808 - Flags: approval-mozilla-aurora?
Comment on attachment 700808 [details] [diff] [review]
Don't show suggestions or prompt in private tabs

Low risk fix for a new feature on Fx20. Approving on aurora
Attachment #700808 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/53dd117b51f2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Status: RESOLVED → VERIFIED
This was fixed before it made to beta. I don't think this needs a relnote.
(In reply to Kevin Brosnan [:kbrosnan] from comment #8)
> This was fixed before it made to beta. I don't think this needs a relnote.

Correct
You need to log in before you can comment on or make changes to this bug.