Private browsing windows recoverable

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: brent.bloxam, Unassigned)

Tracking

18 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

Only tested on Mac OS X. Several issues here:

1. Private browsing windows can be reopened in the same private browsing session
2. Regular browsing windows can be reopened in a private browsing session, including their cookies
3. Private browsing windows can be reopened in a regular browsing session, excluding their cookies

To recreate:

All scenarios assume you've completely quit Firefox (CMD+Q) and are starting with a fresh instance

1. Private browsing windows can be reopened in the same private browsing session:

* Launch Firefox, clear your history
* Switch to Private browsing (CMD+Shift+P)
* Create an identifiable tab (e.g., visit Google, search "private window 1")
* Close the window (CMD+W)
* Create a new window (CMD+N)
* Reopen previous window (CMD+Shift+N)

2. Regular browsing windows can be reopened in a private browsing session, including their cookies:

* Launch Firefox, clear your history
* Create an identifiable tab with an identifiable cookie (e.g., visit GMail, login to your account)
* Close the window (CMD+W)
* Switch to Private browsing (CMD+Shift+P)
* Visit the site you were at, verify the cookie doesn't exist (e.g., visit GMail, you're not logged in)
* Reopen previous window (CMD+Shift+N)
* Refresh the page and see that the cookie still exists (e.g., you can browse your email!)

3. Private browsing windows can be reopened in a regular browsing session, excluding their cookies:

* Launch Firefox
* Close the window (CMD+W) - Omitting this step stops this from working
* Switch to Private browsing (CMD+Shift+P)
* Create an identifiable tab (e.g., visit Google, search "private window 1")
* Close the window (CMD+W)
* Switch to Regular browsing (CMD+Shift+P)
* Reopen previous window (CMD+Shift+N)
* Your private window is back!


Actual results:

See above


Expected results:

Issue 1 is up for debate. I would say if you close a window in Private browsing, you shouldn't be able to get it back

Issue 2 is serious and should not happen

Issue 3 is serious and should not happen
Component: Untriaged → Private Browsing
What version of Firefox are you using?  Is is the latest Nightly?  I cannot reproduce this issue.

Have you tried reproducing this in safe mode?
Blocks: PBnGen
This was with Firefox 17.0.1 (latest up to date release version) on Mac OS X 10.8.x.

I don't imagine there's a way for something similar to happen on Windows as this seems to hinge on being able to close out your Firefox window while the program itself remains open. 

What safe mode are you referring to?
No longer blocks: PBnGen
Please use the Help -> Restart with Add-ons Disabled menu item to restart Firefox in safe mode and see if you can still reproduce this.  Thanks!
Yes, I can confirm I can recreate all three scenarios while using Safe Mode
I have confirmed this on another 10.8.x Mac running Firefox 17.0.1
Version: 17 Branch → 18 Branch
Still possible in today's 18.0 release.
(In reply to comment #6)
> Still possible in today's 18.0 release.

For whatever it's worth, we've completely overhauled private browsing in Firefox 20 which is going to be released in approximately 12 weeks.  I don't believe that we can fix this bug before Firefox 20 is released.  The overhauled private browsing support does not have this bug.
WFM on Firefox 20 (03/25 build). Since Fx 20 will be released in a few days, there will be no new builds of older versions, so I don't think it makes sense to keep this bug open.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.