Fail app validation if type is set to "certified"

VERIFIED FIXED in 2013-01-10

Status

Marketplace
Validation
P5
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

2013-01-10
Points:
---

Details

Attachments

(1 attachment)

94.24 KB, application/zip
Details
(Reporter)

Description

5 years ago
Created attachment 698125 [details]
test app

steps to reproduce:
1. Upload an app with type set to "certified" in the manifest

expected behavior:
App validation fails since certified apps are core gaia apps controlled by the OEM and updated separately.

observed behavior:
test app passes validation without any failures
Priority: -- → P5
(Assignee)

Comment 1

5 years ago
https://github.com/mozilla/app-validator/commit/7ce68f9f3004f1bce8b2375eade83660d287aff6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

5 years ago
verified fixed at https://marketplace-dev.allizom.org/developers/upload/155954dbfcb7467f95f830346eff8af7
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.