Can not assign objects to to window.status

RESOLVED WONTFIX

Status

()

Core
DOM: Core & HTML
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: ekyle, Unassigned)

Tracking

({regression})

20 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox20-)

Details

(Reporter)

Description

6 years ago
In version 17 this HTML will show "works fine".  Version 20 (nightly Jan 4, 2013) does not show anything.  Assigning string values to window.status works find though.

This a bug or a feature?




<HTML>
<HEAD></HEAD>
<BODY>

<div id="myDiv"></div>

<script type="application/javascript">
	MyClass = function(){};

	MyClass.prototype.message = function (message){
		document.getElementById("myDiv").innerHTML = message;
	};

	status = new MyClass();
	status.message("works fine");
</script>


</BODY>
</HTML>

Updated

6 years ago
tracking-firefox20: --- → ?
Keywords: regression, regressionwindow-wanted

Updated

6 years ago
Blocks: 823283
Keywords: regressionwindow-wanted

Comment 1

6 years ago
I think it's a feature -- or, more accurately, not a bug.

This change aligns more closely with every other browser.  Your testcase doesn't work in Opera (Opera Next, if that matters).  It doesn't work in Epiphany, or presumably in any other WebKit-based browser.  And it doesn't work in IE 9.  Given that we want behavior here (and, really, pretty much everywhere) to be interoperably defined by a standard, and that nobody (except us, previously) acts like you want, it seems rather unlikely our prior behavior would ever be considered for standardization.

I argue this is WONTFIX.
OS: Windows 7 → All
Hardware: x86_64 → All
> It doesn't work in Epiphany, or presumably in any other WebKit-based browser.

Doesn't work in Chrome or Safari either.

I agree that this is wontfix.  If you really want this to work, throw a "var" in front of status.  And even then it won't work in WebKit-based browsers or Opera, of course.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
tracking-firefox20: ? → -
You need to log in before you can comment on or make changes to this bug.