Firefox crashes at startup (@ nsXULPrototypeElement::TraceAllScripts(JSTracer*)

VERIFIED FIXED in Firefox 20

Status

()

defect
--
critical
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: xavier114fch, Assigned: mccr8)

Tracking

({crash, regression})

20 Branch
mozilla20
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified)

Details

(crash signature)

Attachments

(1 attachment, 1 obsolete attachment)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20130105 Firefox/20.0
Build ID: 20130105030839

Steps to reproduce:

Launch Firefox after updating to the latest nightly build. It crashes in a few seconds. After reporting the issue and re-open Firefox, and it crashes again.


Actual results:

Crashed. At last it offers me a dialog to choose to start in Safe Mode or Reset my profile. Choose Safe Mode will open the browser and run without any crash again.


Expected results:

Nightly would not crash.
Keywords: topcrash
Can you link to one of your crash reports?
Component: Untriaged → XPCOM
Product: Firefox → Core
Hmm, well, maybe you can't. If you run Firefox in an older version that doesn't crash immediately, then you can go to about:crashes, and it will give links to your crash reports.

I was unable to find any such reports at Crash-Stats.mozilla.com, but I'm not very skilled at using it, so that could just be my fault.
Oh, so it does work in safe mode. Okay. That's good. What addons are you using? You can get this information in about:support under Extensions.
Extensions

        Name

        Version

        Enabled

        ID

        Abduction!
        3.0.16
        false
        {b0e1b4a6-2c6f-4e99-94f2-8e625d7ae255}

        Adblock Plus
        2.2.2a.3606
        false
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Add-on Compatibility Reporter
        2.0
        false
        compatibility@addons.mozilla.org

        Add-on Update Checker
        2.1
        false
        {891f0410-aaa2-11e0-9f1c-0800200c9a66}

        Adobe Acrobat - Create PDF
        2.0
        false
        web2pdfextension@web2pdf.adobedotcom

        Anti-Aliasing Tuner
        11.12.01.01
        false
        aatuner@hotmint.com

        DownThemAll! *nightly*
        3.0b1pre.20130105.3375
        false
        dta@downthemall.net

        Element Hiding Helper for Adblock Plus
        1.2.4a.446
        false
        elemhidehelper@adblockplus.org

        Firebug
        1.11.1
        false
        firebug@software.joehewitt.com

        Firefox Share (alpha)
        0.2.3
        false
        fx-share-addon@mozilla.org

        Nightly Tester Tools
        3.4pre
        false
        {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

        OpenAttribute
        0.9.8
        false
        firefox@openattribute.com

        PDF Viewer
        0.7.45
        false
        uriloader@pdf.js

        Status-4-Evar
        2012.11.11.16b
        false
        status4evar@caligonstudios.com
Looks like mRoot is null. I was wondering if that might be a problem...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted patch null check (obsolete) — Splinter Review
Thanks for the reports!

Windows build: https://tbpl.mozilla.org/?tree=Try&rev=a27d33a46501
I'll try to link to the installation when it is finished.

This patch does a null check, but also asserts in debug builds, to make it easier to tell if the condition is hit.

Could you try disabling a few addons at a time to figure out which one might be causing the problem? Thanks.
Assignee: nobody → continuation
Seems like the extension "Adobe Acrobat - Create PDF" caused this issue. Have tried to disable all extensions and enabled one at a time. Got crash after enabling this one. 

Disabled all extensions again and only enabled Acrobat - and crashed. Got the same signature.
https://crash-stats.mozilla.com/report/index/bp-b4ac0a8e-f27b-483b-82b4-9fdd92130105
Severity: normal → critical
Crash Signature: [@ nsXULPrototypeElement::TraceAllScripts(JSTracer*) ]
Keywords: topcrashcrash, regression
Posted patch null checkSplinter Review
Untested, but it should be okay, at least in terms of passing tests.
https://tbpl.mozilla.org/?tree=Try&rev=40b9fe590403

Thanks for figuring out what addon caused it! Unfortunately, I don't have Acrobat so I won't be able to confirm the fix locally.
Attachment #698300 - Attachment is obsolete: true
Attachment #698302 - Flags: review?(bugs)
Comment on attachment 698302 [details] [diff] [review]
null check

Sorry that I missed this while reviewing.
Attachment #698302 - Flags: review?(bugs) → review+
Andrew, will you be able to land this to m-c soon? If not, I could, so that the fix would be in the
next nightly.
Yeah, I can do that in an hour or so, when the try run finishes. Good point, I'll land directly on m-c.
Thanks again for the report, Xavier Fung. If you could confirm with tomorrow's Nightly that this works (or with the build here: http://ftp-scl3.mozilla.com/pub/mozilla.org/firefox/try-builds/amccreight@mozilla.com-a27d33a46501/try-win32/ ) that would be useful.

https://hg.mozilla.org/mozilla-central/rev/16574882a159
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Blocks: 826922
Can confirm that today's nightly (Jan 6) does not crash. Thanks Andrew!
I confirm the fix is verified on Latest Nightly 22.0a1 and on FF 20.b1 on Windows 8 x64.

Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130220104816)

Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20130220 Firefox/22.0(20130220031126)

Update to FF 20.b1 works only if you modify channel from Firefox/defaults/pref/channel-pref.js  from beta to betatest.

Based on my verifications and on Comment 14 this issue looks to be verified.

Thanks Xavier for Confirm!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.