java.lang.NullPointerException: at org.mozilla.gecko.db.LocalBrowserDB.desktopBookmarksExist(LocalBrowserDB.java)

RESOLVED FIXED in Firefox 25

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Assigned: ckitching)

Tracking

({crash})

Trunk
Firefox 25
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox17 affected, firefox18 affected, firefox19 affected, firefox20 affected, firefox21 affected, firefox22 affected, firefox23 affected, firefox24 affected, firefox25 fixed)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

4 years ago
There are about 100 crashes across all channels, including bp-00c1ea70-8034-40d6-9562-41f122130102.

java.lang.NullPointerException
	at org.mozilla.gecko.db.LocalBrowserDB.desktopBookmarksExist(LocalBrowserDB.java:419)
	at org.mozilla.gecko.db.LocalBrowserDB.getBookmarksInFolder(LocalBrowserDB.java:357)
	at org.mozilla.gecko.db.BrowserDB.getBookmarksInFolder(BrowserDB.java:177)
	at org.mozilla.gecko.BookmarksTab$BookmarksQueryTask.doInBackground(BookmarksTab.java:359)
	at org.mozilla.gecko.BookmarksTab$BookmarksQueryTask.doInBackground(BookmarksTab.java:346)
	at android.os.AsyncTask$2.call(AsyncTask.java:264)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:305)
	at java.util.concurrent.FutureTask.run(FutureTask.java:137)
	at android.os.AsyncTask$SerialExecutor$1.run(AsyncTask.java:208)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1076)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:569)
	at java.lang.Thread.run(Thread.java:856)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.db.LocalBrowserDB.desktopBookmarksExist%28LocalBrowserDB.java%29
(Reporter)

Updated

4 years ago
status-firefox21: --- → affected
(Reporter)

Updated

4 years ago
status-firefox23: --- → affected
status-firefox24: --- → affected
(Reporter)

Updated

4 years ago
status-firefox22: --- → affected
(Reporter)

Updated

4 years ago
status-firefox25: --- → affected
(Assignee)

Updated

4 years ago
Assignee: nobody → ckitching
(Assignee)

Updated

4 years ago
Depends on: 887820
(Assignee)

Comment 1

4 years ago
It appears this bug is caused by the Cursor in desktopBookmarksExist being null when close() is called, causing the NullPointerException.
The patch I just submitted to 887820 corrects this problem.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
status-firefox25: affected → fixed
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.