Closed Bug 827235 Opened 7 years ago Closed 7 years ago

Add plugin-hang-ui@BIN_SUFFIX@ to SeaMonkey package manifest

Categories

(SeaMonkey :: Installer, defect)

defect
Not set

Tracking

(seamonkey2.17 fixed, seamonkey2.18 fixed)

RESOLVED FIXED
seamonkey2.19
Tracking Status
seamonkey2.17 --- fixed
seamonkey2.18 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Details

Attachments

(1 file)

See http://hg.mozilla.org/mozilla-central/rev/1308210aefb4 (Bug 805591), a new file has been added to the FF package manifest to handle hung plugins. SeaMonkey package manifest should include that file, too.
Attached patch PatchSplinter Review
Very easy to review.
Assignee: installer → bugzilla
Status: NEW → ASSIGNED
Attachment #730093 - Flags: review?(philip.chee)
Comment on attachment 730093 [details] [diff] [review]
Patch

r=me

You might also consider (in other bugs) porting installer changes from:

Bug 752982 - Part 1, implement captive portal detection service.
(probably responsible for some of our xpcshell oranges)
Bug 648407 - Allow to fold NSPR, NSS and SQLite libraries all together.
Bug 811548 - Move PageThumbs.jsm from /browser to /toolkit
Attachment #730093 - Flags: review?(philip.chee) → review+
Pushed: https://hg.mozilla.org/comm-central/rev/f500f6d4e9c7
Target Milestone: --- → seamonkey2.19
Comment on attachment 730093 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Bad user experience, Bug 805591 added a plugin hang UI that should also be included in SeaMonkey
Testing completed (on m-c, etc.): Feature works fine in Firefox, I tested this locally for quite a few weeks already (as the feature was included when building on your own PC)
Risk to taking this patch (and alternatives if risky): New GUI only gets called when a plugin causes problems, plus has already been tested in Firefox; so low risk I think
String changes made by this patch: -
Attachment #730093 - Flags: approval-comm-beta?
Attachment #730093 - Flags: approval-comm-aurora?
Comment on attachment 730093 [details] [diff] [review]
Patch

a=me
Attachment #730093 - Flags: approval-comm-beta?
Attachment #730093 - Flags: approval-comm-beta+
Attachment #730093 - Flags: approval-comm-aurora?
Attachment #730093 - Flags: approval-comm-aurora+
Pushed to comm-beta: https://hg.mozilla.org/releases/comm-beta/rev/fe3aceeaedb6
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This landed after the last 2.17 beta was tagged, so unless there'll be another 2.17 build, this is will not be fixed for SM 2.17 (but for anyone who builds default off comm-beta or to-be comm-release). Adjusted flags accordingly.
Jens: As far as I know the final SM 2.17 build will be built off the latest comm-beta revision, not off the last SM 2.17 beta build (Callek talked to me about this bug fix here :)
Or better said: The latest comm-beta revision will be moved to comm-release and then SM 2.17 will be built using that revision.
Hmm OK, don't know how releng actually handles this. Until now I thought we wouldn't introduce any changes between the last beta and the final build, the rationale being that we would not have any beta user feedback for such changes. But this is not my call to make; esp. if you already talked to Callek about this.
Jens: The feature itself has been tested for a quite a while already in Firefox (and by me locally, though local test coverage could be better ;-).
You need to log in before you can comment on or make changes to this bug.