Closed Bug 827513 Opened 7 years ago Closed 7 years ago

Remove NotificationsComponents.manifest from SeaMonkey installer package manifest

Categories

(SeaMonkey :: Installer, defect, blocker)

defect
Not set
blocker

Tracking

(seamonkey2.17 fixed)

RESOLVED FIXED
seamonkey2.18
Tracking Status
seamonkey2.17 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Details

Attachments

(1 file)

http://hg.mozilla.org/mozilla-central/rev/7647b05aa3f0 removed services/notifications, so components/NotificationsComponents.manifest needs to be removed from the SeaMonkey installer package manifest, too.
Attached patch PatchSplinter Review
Removes everything related to MOZ_SERVICES_NOTIFICATIONS from comm-central. The second change in removed-files.in is needed because of the modules/* directive in the installer package manifest, the third change is for non-omnijar builds.
Assignee: installer → bugzilla
Status: NEW → ASSIGNED
Attachment #698967 - Flags: review?(bugspam.Callek)
Comment on attachment 698967 [details] [diff] [review]
Patch

Review of attachment 698967 [details] [diff] [review]:
-----------------------------------------------------------------

rs+ as bustage fix, I'll do a *real* review within the week though anyway, so leaving request open.
Attachment #698967 - Flags: feedback+
Pushed: https://hg.mozilla.org/comm-central/rev/d744283dd331
Target Milestone: --- → seamonkey2.18
Comment on attachment 698967 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: SeaMonkey won't compile on comm-aurora
Testing completed (on m-c, etc.): Works on comm-central, this patch ports Firefox Bug 791869 to SeaMonkey
Risk to taking this patch (and alternatives if risky): build change only, no risk
String changes made by this patch: -
Attachment #698967 - Flags: approval-comm-aurora?
Comment on attachment 698967 [details] [diff] [review]
Patch

a=me for comm-aurora.
Attachment #698967 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed: https://hg.mozilla.org/releases/comm-aurora/rev/131f2f3e65b8
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 698967 [details] [diff] [review]
Patch

Review of attachment 698967 [details] [diff] [review]:
-----------------------------------------------------------------

...and I have a strange notion of "within the week"

::: suite/installer/package-manifest.in
@@ -586,5 @@
>  @BINPATH@/@PREF_DIR@/services-aitc.js
>  #endif
> -#ifdef MOZ_SERVICES_NOTIFICATIONS
> -@BINPATH@/@PREF_DIR@/services-notifications.js
> -#endif

Firefox kept this in, but I don't think they meant to.
Attachment #698967 - Flags: review?(bugspam.Callek) → review+
You need to log in before you can comment on or make changes to this bug.