Closed Bug 827654 Opened 12 years ago Closed 12 years ago

about:compartments triggers "ASSERTION: QueryInterface needed" in nsThread::ProcessNextEvent

Categories

(Core :: XPCOM, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox18 --- wontfix
firefox19 - fixed
firefox20 - fixed
firefox21 - fixed
b2g18 - fixed

People

(Reporter: jruderman, Assigned: bzbarsky)

References

Details

(Keywords: assertion, regression)

Attachments

(2 files)

Attached file stack
1. Launch a debug build
2. Load about:compartments

###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr', file nsCOMPtr.h, line 505
The code added in bug 814771 has:

  NS_IMPL_THREADSAFE_ISUPPORTS1(nsCancelableRunnable, nsICancelableRunnable)

This is wrong: it should also do nsIRunnable.
Blocks: 814771
I wonder whether it makes sense to add about:compartments as a crashtest....
Attachment #698988 - Flags: review?(bugs)
Assignee: nobody → bzbarsky
Whiteboard: [need review]
Good catch, we'll have to land this on mozilla-b2g18 too.
And on Aurora 20 and beta 19, right?
Comment on attachment 698988 [details] [diff] [review]
This fixes the bug

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 814771 
User impact if declined: Some things may not work, but hard to tell what up
   front.
Testing completed: Passes test in bug.
Risk to taking this patch (and alternatives if risky): Very very low risk
String or UUID changes made by this patch: None.
Attachment #698988 - Flags: approval-mozilla-beta?
Attachment #698988 - Flags: approval-mozilla-b2g18?
Attachment #698988 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/integration/mozilla-inbound/rev/1f7a46d13daa
Whiteboard: [need review]
Target Milestone: --- → mozilla21
(In reply to Boris Zbarsky (:bz) from comment #2)
> I wonder whether it makes sense to add about:compartments as a crashtest....

I think that's a good idea.  We should add all the about: pages as crashtests
to catch assertions etc.
Attachment #698988 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
https://hg.mozilla.org/mozilla-central/rev/1f7a46d13daa
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Comment on attachment 698988 [details] [diff] [review]
This fixes the bug

Approving based upon the risk evaluation, but no need to track without known user impact.
Attachment #698988 - Flags: approval-mozilla-beta?
Attachment #698988 - Flags: approval-mozilla-beta+
Attachment #698988 - Flags: approval-mozilla-aurora?
Attachment #698988 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: