Highlighted key becomes dark (glitch)

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: atsai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-tracking)

(Reporter)

Description

5 years ago
For now, if we press on the keyboard with two fingers the first one will not be sent.
The first highlighted key ("s" in this example) becomes dark

STR:
1. Launch any app for typing, such as SMS, browser, or any other apps with textfields.
2. Click on a key ("s" is this example)
3. Click on any other key, and drag around the keyboard

Expected Result:
*. The highlighted key turns off when the second key is clicked

Actual Result:
*. The "s" is not send and the highlighted area becomes darker
(Reporter)

Updated

5 years ago
Depends on: 827811
Yep, confirmed. There's some weirdness happening here. Flagging for ux-most-wanted in the hope that resolving my create performance improvements (perhaps a long shot, but every bit helps).

Rudy, who is the best person to work on this?
Flags: needinfo?(rlu)
Whiteboard: u=user c=keyboard s=ux-most-wanted
Hi Josh, Al,

Should be a dupe of Bug 826152, a rendering issue of platform side.
Will need to verify this issue after that one is fixed.

Thanks.
Depends on: 826152
No longer depends on: 827811
Flags: needinfo?(rlu)
QA Contact: wachen → whsu
Summary: [Keyboard] Highlighted key becomes dark → Highlighted key becomes dark (glitch)
We're seeing this resolved by markup changes in bug #860318 which remove background images. Will follow up and close as resolved once those land.

Updated

5 years ago
Whiteboard: u=user c=keyboard s=ux-most-wanted → ux-tracking
Close this as Bug 860318 workarounds this issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 827811
Resolution: --- → FIXED

Comment 5

4 years ago
Thanks for the help!
Verified patches. I cannot reproduce it.

* Verified Build: (Device -> Buri)
 - Gaia      47049555282a9a01fb60d1e1421b57e2810c96f5
 - Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
 - BuildID   20140121004137
 - Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.