Building testpilot broken, breaking building Aurora nightlies

RESOLVED FIXED in Firefox 20

Status

defect
--
blocker
RESOLVED FIXED
7 years ago
7 months ago

People

(Reporter: philor, Assigned: glandium)

Tracking

({regression})

Trunk
mozilla21
Dependency tree / graph

Firefox Tracking Flags

(firefox20+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

e.g. https://tbpl.mozilla.org/php/getParsedLog.php?id=18588038&tree=Mozilla-Aurora

cd testpilot@labs.mozilla.com && \
	/usr/bin/zip -r9XD /builds/slave/m-aurora-lnx-ntly/build/obj-firefox/browser/app/profile/extensions/../../../../dist/bin/distribution/extensions/testpilot@labs.mozilla.com.xpi * -x \*.in -x \*.mkdir.done
zip I/O error: No such file or directory
zip error: Could not create output file (/builds/slave/m-aurora-lnx-ntly/build/obj-firefox/browser/app/profile/extensions/../../../../dist/bin/distribution/extensions/testpilot@labs.mozilla.com.xpi)
make[8]: Leaving directory `/builds/slave/m-aurora-lnx-ntly/build/obj-firefox/browser/app/profile/extensions'
make[8]: *** [/builds/slave/m-aurora-lnx-ntly/build/obj-firefox/browser/app/profile/extensions/../../../../dist/bin/distribution/extensions/testpilot@labs.mozilla.com.xpi] Error 15

Since bug 822017 is the only time we've touched it in months, it seems likely.
Ehsan - can you take a look this morning? We'll want to spin Aurora as soon as this is resolved.
Assignee: nobody → ehsan
Posted patch Patch (v1) (obsolete) — Splinter Review
The problem is that we never create dist/bin/distribution/extensions.

This patch fixes it.
Attachment #699271 - Flags: review?(mh+mozilla)
Comment on attachment 699271 [details] [diff] [review]
Patch (v1)

Review of attachment 699271 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/profile/extensions/Makefile.in
@@ +28,4 @@
>  GARBAGE += $(all_xpis)
>  
>  $(all_xpis): $(DISTROEXT)/%.xpi: $(call mkdir_deps,$(DISTROEXT)) libs-%
> +	mkdir -p $(DISTROEXT) && \

$(call mkdir_deps,$(DISTROEXT)) is supposed to create that directory.
Attachment #699271 - Flags: review?(mh+mozilla) → review-
(In reply to comment #3)
> Comment on attachment 699271 [details] [diff] [review]
>   --> https://bugzilla.mozilla.org/attachment.cgi?id=699271
> Patch (v1)
> 
> Review of attachment 699271 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/app/profile/extensions/Makefile.in
> @@ +28,4 @@
> >  GARBAGE += $(all_xpis)
> >  
> >  $(all_xpis): $(DISTROEXT)/%.xpi: $(call mkdir_deps,$(DISTROEXT)) libs-%
> > +	mkdir -p $(DISTROEXT) && \
> 
> $(call mkdir_deps,$(DISTROEXT)) is supposed to create that directory.

Well, it doesn't.  See the build log.
Assignee: ehsan → mh+mozilla
Subtle case of variables not being there before including rules.mk. Can't move everything since INSTALL_TARGETS requires rules.mk to be included afterwards. And no need for an ifdef because all_xpis is not defined unless the original ifdef matches.
Attachment #699285 - Flags: review?(ted)
Attachment #699271 - Attachment is obsolete: true
Attachment #699285 - Flags: review?(ted) → review+
Comment on attachment 699285 [details] [diff] [review]
Move the rules from bug 822017 after including rules.mk

This blocks builds.
Attachment #699285 - Flags: approval-mozilla-aurora?
Comment on attachment 699285 [details] [diff] [review]
Move the rules from bug 822017 after including rules.mk

[Triage Comment]
Approving for Aurora, so that we can spin up a nightly. Thanks all!
Attachment #699285 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/3a5db98b87e4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Component: Build Config → General
Product: Firefox → Firefox Build System
Keywords: regression
Target Milestone: Firefox 21 → mozilla21
You need to log in before you can comment on or make changes to this bug.