(Days) Older Version of Open Tabs restored after restart

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: SEKCobra, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I restarted firefox after a few weeks of constantly having it running (with standby inbetween) without issues.


Actual results:

For some reason, the open tabs that were restored were a few days old, which was very odd. The history seems fine.


Expected results:

It should have opened the tabs that were open right before, like always.

Updated

5 years ago
Component: Untriaged → Session Restore

Comment 1

4 years ago
This is the same issue I'm having recently... except in my case the restart of firefox is usually due to crashing every couple days or so (still not sure what's causing that). I'm running ff 25.0.1 on Windows. The tabs that are restored are anywhere from several hours to a day old (so far). I also happen to have on the order of 250-300 tabs open.

Latest crash report (if it's helpful at all): https://crash-stats.mozilla.com/report/index/4ce795d4-3c2e-4ce4-a52f-f39772131218

Comment 2

3 years ago
Specific scenario:
My Windows 7 experienced a Blue Screen of Death restart due to something possibly unrelated to Firefox. And, when I started Firefox again, my most recent tabs and tab groups were gone. They were instead replaced with an older session.

Unfortunately, my Firefox got updated in the interim and I don't have the exact version details. But, it definitely was 32 or 33.
Do you still encounter this issue?
Flags: needinfo?(selfacclaimedgenius)
Flags: needinfo?(sekcobra)
Whiteboard: [closeme 2016-09-25]
(Reporter)

Comment 4

a year ago
Negative, but I've changed Firefox install several times by now and am on Waterfox these days.
Flags: needinfo?(sekcobra)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2016-09-25]

Updated

a year ago
Flags: needinfo?(selfacclaimedgenius)
You need to log in before you can comment on or make changes to this bug.