Selected Tab Overlaps Finished Download Animation

RESOLVED FIXED in Firefox 20

Status

()

Firefox
Downloads Panel
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: shorlander, Assigned: mak)

Tracking

({polish})

unspecified
Firefox 21
x86
Mac OS X
polish
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 699302 [details]
Tab Overlapping Arrow Animation

If the selected tab is near the download button the download complete animation appears under the selected tab. I have only tested this on OSX.
Blocks: 747422
Keywords: polish
plausible code points involved:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/pinstripe/browser.css#2386
probably gnomestripe has similar problem
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/gnomestripe/global/tabbox.css#52
So stephen confirmed the problem is that z-index, unfortunately it's not enough to just define z-index and position on the notification since looks like they pertain to different stacking contexts.
I still have to test gnomestripe.
setting z-index and position on #downloads-indicator-anchor appears to fix the problem.
And gnomestripe doesn't appear to be affected.
Created attachment 699478 [details] [diff] [review]
patch v1.0
Attachment #699478 - Flags: review?(shorlander)
Created attachment 699480 [details] [diff] [review]
patch v1.1

just better comment
Attachment #699478 - Attachment is obsolete: true
Attachment #699478 - Flags: review?(shorlander)
Attachment #699480 - Flags: review?(shorlander)
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Reporter)

Updated

5 years ago
Attachment #699480 - Flags: review?(shorlander) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e5ac5de0c94a
Target Milestone: --- → Firefox 21
Comment on attachment 699480 [details] [diff] [review]
patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: incomplete ui
Testing completed (on m-c, etc.): m-i (merge pending)
Risk to taking this patch (and alternatives if risky): limited to the feature
String or UUID changes made by this patch: none
Attachment #699480 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/e5ac5de0c94a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/e5ac5de0c94a
https://hg.mozilla.org/mozilla-central/rev/e5ac5de0c94a
Attachment #699480 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/249c11a3f318
status-firefox20: --- → fixed
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130218 Firefox/20.0
Build ID: 20130218042018

In some circumstances, this issue is still reproducible:

Steps to reproduce:
1. Navigate to https://addons.mozilla.org/en-US/firefox/complete-themes/
2. Install FXChrome theme and restart.
3. Open several tabs so that the last opened one is near the downloads indicator
4. Perform any download.

Actual results:
If the selected tab is near the download button the download complete animation appears under the selected tab.

Please see the screencast for more details:
http://screencast.com/t/8Q4pIurjY9jS

So far I reproduced this issue only with FXChrome theme installed (no other theme that I installed showed this behavior). 

Marco, would you prefer me to reopen this bug or file a new one?
Unfortunately we cannot fix third party themes, so I don't think it's worth a bug
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130220104816

Verified on Firefox 20 beta 1 that with the default theme, the selected tab does not overlap the finished download animation. Based on this and on Comment 13, setting the tracking flag for Firefox 20 to Verified.
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.