If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

gesture detector is reporting taps as double taps

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: djf, Assigned: djf)

Tracking

({regression})

unspecified
B2G C4 (2jan on)
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This is a regression from bug 823619.

Under the new event model, when the user taps, we get these events:

  touchstart touchend mousemove mousedown mouseup click

Apps that use gesture_detector.js (but do not use mouse_event_shim.js) will get these events from the gesture detector:

  tap tap dbltap

That is because the gesture detector generates a tap for the touchstart/touchend pair and the mousedown/mouseup pair.

This is a regression, and we should block on it.

Fortunately, I've got a fix in my patch for bug 827551. The fix is to modify gesture detector so that if we ever receive a touch event, we stop listening for mouse events.

I'll attach the patch soon.
(Assignee)

Comment 1

5 years ago
Nominating blocking.

Cc'ing cjones since it is a regression from 823619. (Sorry I didn't catch this one, Chris!)

The only place I see a symptom of this bug is when you preview a photo in the camera app by tapping on the filmstrip.  tapping on the photo zooms in even though it is supposed to be a double tap to zoom.
Blocks: 823619
blocking-basecamp: --- → ?
Keywords: regression
(Assignee)

Comment 2

5 years ago
Created attachment 699381 [details]
link to patch on github

The attached pull request fixes this bug and also 827551.  Looking for a reviewer...
Assignee: nobody → dflanagan
(Assignee)

Comment 3

5 years ago
Comment on attachment 699381 [details]
link to patch on github

Chris,

Is this something you can review?
Attachment #699381 - Flags: review?(cpeterson)
re 3: I did a quick review... One nit and one question. I don't understand 100% of GD but this makes sense to me.

r=lightsofapollo
(Assignee)

Comment 5

5 years ago
Comment on attachment 699381 [details]
link to patch on github

Switching review to James, and marking his r+.

And requesting approval to land from Vivien, in case this doesn't get marked blocking.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 823619

User impact if declined: taps may be generate dbltap events in some apps.
Testing completed: yes, this patch fixes the photo viewer in the camera app and does not break other users of gesture detector like gallery and  browser

Risk to taking this patch (and alternatives if risky):
Attachment #699381 - Flags: review?(cpeterson)
Attachment #699381 - Flags: review+
Attachment #699381 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 6

5 years ago
It looks like I reviewed the patch myself, but actually, I just set the flag after I got a r+ from lightsofapollo
LGTM. I added some comments on the GitHub PR, but nothing that should delaying this fix from landing.
(Assignee)

Comment 8

5 years ago
I've updated the github PR to address nits from both Chris and James.
Attachment #699381 - Flags: approval-gaia-master?(21) → approval-gaia-master+
https://github.com/mozilla-b2g/gaia/commit/28f2eb778f5d12e1d13fcd965160519d6593bf2e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C4 (2jan on)

Comment 10

5 years ago
Device: Unagi
Build: 20130114073222
Does not repro on this build and device.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.