Closed Bug 827995 Opened 8 years ago Closed 8 years ago

Avoid spending a lot of time in sprintf while assembling for ARM

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
blocking-basecamp -
Tracking Status
firefox17 --- wontfix
firefox18 --- wontfix
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed
firefox-esr10 --- wontfix
firefox-esr17 --- wontfix
b2g18 --- fixed

People

(Reporter: jrmuizel, Unassigned)

Details

Attachments

(1 file)

During a profile of JS execution on B@G we're spending 10% of the time in __vfprintf. At least some of this is in the arm assembler. Since we're not actually using the strings we're printing we'd be better off not printing them.
Attachment #699395 - Flags: review?(bhackett1024)
blocking-basecamp: --- → ?
Attachment #699395 - Flags: review?(bhackett1024) → review+
This appears to come, in part at least, from the initial check in of bug 564953.
Boy it'd be great to get this into B2Gv1!
Comment on attachment 699395 [details] [diff] [review]
Avoid spending a lot of time in sprintf while assembling for ARM

[Triage Comment]
Attachment #699395 - Flags: approval-mozilla-b2g18+
not blocking.  uplift sounds great.
blocking-basecamp: ? → -
https://hg.mozilla.org/mozilla-central/rev/de0adc1cf18a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Comment on attachment 699395 [details] [diff] [review]
Avoid spending a lot of time in sprintf while assembling for ARM

[Approval Request Comment]
Regression caused by (bug #): We've had this problem for a long time.
User impact if declined: Slower JS compilation on ARM
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): Just disables some debug code that should've been disabled. There should be basically no risk to this at all.
Attachment #699395 - Flags: approval-mozilla-beta?
Attachment #699395 - Flags: approval-mozilla-aurora?
Keywords: checkin-needed
Comment on attachment 699395 [details] [diff] [review]
Avoid spending a lot of time in sprintf while assembling for ARM

Considering where we are in the cycle (5 more beta's before release :) )and based on the risk profile of this bug vs the perf win, approving on branches
Attachment #699395 - Flags: approval-mozilla-beta?
Attachment #699395 - Flags: approval-mozilla-beta+
Attachment #699395 - Flags: approval-mozilla-aurora?
Attachment #699395 - Flags: approval-mozilla-aurora+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.