Firefox 18 mac font rendering not properly on display NOT retina

RESOLVED DUPLICATE of bug 828206

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 828206
6 years ago
6 years ago

People

(Reporter: Fabri, Unassigned)

Tracking

({regression})

18 Branch
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox18-)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 699431 [details]
Facebook sidebar - should be visible the rendering

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151948

Steps to reproduce:

I went on Facebook and few other websites


Actual results:

Fonts are displayed in a different way from Firefox 18 on a mac without a display retina. I can really see the different rendering on Facebook (news stream) and although the difference is very light, it's highly dangerous and annoying for the eyes!!!

Please fix it!

System: Firefox 18 on Mac OS X 10.7.5 non retina


Expected results:

The fonts should be displayed as on firefox 17. I think it's because the new retina ready resolution?
(Reporter)

Comment 1

6 years ago
I add these informations:
1. I tried to resent firefox profile, the issue is still there
2. on facebook site at the beginning it seems everything fine, but after trying to scroll down and then up again, you can really see the difference!
(Reporter)

Updated

6 years ago
Hardware: x86 → x86_64
Component: Untriaged → Graphics: Text
Product: Firefox → Core

Comment 2

6 years ago
I confirm this thing (a bug), it also does it on sites like YouTube or Yahoo and maybe on many others.
Firefox 18.0 on Mac OS X Snow Leopard (10.6.8).

Comment 3

6 years ago
I can confirm this bug:
firefox 18
Windows xp sp3

It is happening specially in some Youtube pages, it's really annoying, the text looks awful
confirmed by independent comments
Status: UNCONFIRMED → NEW
tracking-firefox18: --- → ?
Ever confirmed: true
Keywords: regression

Comment 5

6 years ago
(In reply to Fresnel from comment #3)
> I can confirm this bug:
> firefox 18
> Windows xp sp3
> 
> It is happening specially in some Youtube pages, it's really annoying, the
> text looks awful

Maybe a dupe of bug 828206. Could you confirm this comment, please?
https://bugzilla.mozilla.org/show_bug.cgi?id=828206#c3
Flags: needinfo?(losidea)
Blocks: 785330

Comment 6

6 years ago
(In reply to Loic from comment #5)
> (In reply to Fresnel from comment #3)
> > I can confirm this bug:
> > firefox 18
> > Windows xp sp3
> > 
> > It is happening specially in some Youtube pages, it's really annoying, the
> > text looks awful
> 
> Maybe a dupe of bug 828206. Could you confirm this comment, please?
> https://bugzilla.mozilla.org/show_bug.cgi?id=828206#c3

yeap, that's it.
Flags: needinfo?(losidea)

Comment 7

6 years ago
(In reply to Fresnel from comment #6)
> yeap, that's it.

Thanks for the feedback, anyway as you're on Windows, I'm not sure your issue is related to this current bug which is about Mac OSX, but clearly to bug 828206.

Comment 8

6 years ago
I can also confirm this bug.

Behavior began immediately upon the update. Text renders properly until scrolling. Then text - especially noticeable in Lucida Grande 11px on Facebook -- thins out, so strokes vary in thickness across the screen. Yoogly.

Firefox 18.0
Mac OS X Lion (10.7.5).
Since this seems to also happen on Windows, this can't have anything to do with HiDPI support on the Mac.
No longer blocks: 785330

Comment 10

6 years ago
So the Mac reporters need to test Firefox 21 to confirm it's fixed or not. Windows users confirmed it's fixed in Nightly (http://nightly.mozilla.org/).
Flags: needinfo?(masini.fabrizio)
> Windows users confirmed it's fixed in Nightly

Are you referring to bug 828206, and particularly to bug 828206 comment #6?

Comment 12

6 years ago
Yes, and its duplicate.
(Reporter)

Comment 13

6 years ago
Excuse me but I'm not a developer, and why Firefox 21? I would like not to wait for firefox 21 to get this issue fixed since we are on version 18 and I would not update for sure to version 18 because this bug...
Flags: needinfo?(masini.fabrizio)
Fabri, you (or someone else who's seen this bug on OS X) needs to test a current trunk (aka mozilla-central) nightly to see if this bug has been fixed there.
(Reporter)

Comment 15

6 years ago
ok but can you explain me why not for example firefox 19?...I'm sorry but I'm a bit noob in these issues, I just reported the bug hoping to help the community developing the case :)
> ok but can you explain me why not for example firefox 19?

Because bug 828206 hasn't yet been fixed there.

(This bug may be a duplicate of bug 828206.  But we can't know for sure until someone tests a current trunk (21-branch) nightly.)
(Reporter)

Comment 17

6 years ago
In Firefox 21 the issue is solved as in Firefox 17 :)
Excellent!  Thanks for checking.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828206
(Reporter)

Comment 19

6 years ago
so is there a way this bug is gonna be fixed before firefox 21? :) I would like to get my hands on IonMonkey without losing my eyes on facebook :D
> so is there a way this bug is gonna be fixed before firefox 21? :)

It's possible, but there's no guarantee.  You (and others who are interested in this bug) will need to follow up at bug 828206.

As of now, we don't know what patch "fixed" bug 828206.  Until we do, there's no way we can accelerate fixing that bug (in some earlier version than the FF 21 release).

The only people who can help with this are developers, or at least people who are comfortable building large, complex programs like Firefox.  See bug 828206 comment #6.  If you can help, please follow up there.
(Reporter)

Comment 21

6 years ago
Reading the other bug I tried to re-activate my hardware acceleration (that I deactivated because I've a mac from 2008 with poor graphics) and now the issue disappeard.

I invite all the other persons that had the issue to try this workaround :):
reactivating the hardware acceleration in preferences>advanced>use hardware acceleration when available

Comment 22

6 years ago
(In reply to Fabri from comment #21)
> Reading the other bug I tried to re-activate my hardware acceleration (that
> I deactivated because I've a mac from 2008 with poor graphics) and now the
> issue disappeard.
> 
> I invite all the other persons that had the issue to try this workaround :):
> reactivating the hardware acceleration in preferences>advanced>use hardware
> acceleration when available

I already had hardware acceleration on, it's not a fix for me. Firefox 21 is ok but when will it be available? We're at version 18 now. Would be good if a version 18.0.1 was released soon to fix this bug. Or create 2 versions, 1 for the Retina display owners and the other for no Retina display owners that works well like Firefox 17 and includes the security patches.

Updated

6 years ago
tracking-firefox18: ? → -

Comment 23

6 years ago
Is there a way to manually, temporarily, disable HiDPI support in Firefox 18 and in 18.0.1 completely and make it behave like it was in version 17.0.1? I tried setting this value (gfx.hidpi.enabled) in about:config to 0 and to -1 but it doesn't change anything, unfortunately.
You're doing the right thing to disable HiDPI support.

But it won't help with this bug, which (apparently) has nothing to do with HiDPI support.

Comment 25

6 years ago
(In reply to Steven Michaud from comment #24)
> You're doing the right thing to disable HiDPI support.
> 
> But it won't help with this bug, which (apparently) has nothing to do with
> HiDPI support.

I've found Firefox version 17.0.2esr (Extended Support Release) that doesn't have this bug and it's OK for me. I'll stick with this version until version 21 comes out or a fixed version comes out before 21, thank you!
:D

Comment 26

6 years ago
Magically fixed in Firefox 19.0!
Thank you all who solved it! 
:)
(Reporter)

Comment 27

6 years ago
fixed, bug can be closed
You need to log in before you can comment on or make changes to this bug.