Closed Bug 828120 Opened 7 years ago Closed 7 years ago

social panel buttons are too wide on Mac

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21

People

(Reporter: Gavin, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached patch PatchSplinter Review
This combines the buttons and removes the extra margins that were noted before. 

As I mentioned in the previous bug, the toolbaritems are still a bit too wide, but I can't figure out how to get them any narrower.
Attachment #699816 - Flags: review?(mnoorenberghe+bmo)
Status: NEW → ASSIGNED
Comment on attachment 699816 [details] [diff] [review]
Patch

Review of attachment 699816 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the change

::: browser/themes/pinstripe/browser.css
@@ +3815,5 @@
>  }
>  
> +/* Needed to make the adjacent buttons combine */
> +.social-notification-container > .toolbarbutton-1,
> +#social-provider-button {

The comment is only for the second rule and since the margin has a different purpose for each rule, the property can be moved to the two existing rulesets:
  #social-provider-button
  .social-notification-container > .toolbarbutton-1
Attachment #699816 - Flags: review?(mnoorenberghe+bmo) → review+
Thanks, I made the changes on the patch that got landed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e6c4fd2603f9
https://hg.mozilla.org/mozilla-central/rev/e6c4fd2603f9
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Duplicate of this bug: 829868
You need to log in before you can comment on or make changes to this bug.