Closed Bug 828192 Opened 7 years ago Closed 6 years ago

Fx 18 regression: bad cleartype on selected menu items

Categories

(Core :: Graphics: Text, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 812871

People

(Reporter: al_9x, Unassigned)

Details

Attachments

(1 file)

xp (reproducible in vm), new profile, select/highlight any menu item (e.g. Main Menu->File->New Window)
Blocks: 677144
Attached image 14.0 vs latest nightly
I can confirm that I see this (in WinXP on VirtualBox). Firefox 17.0.1 is OK; Firefox 18.0 has the poorer rendering, as shown in al_9x's screenshot from Nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Using m-c nightly builds:

Good: 2012-09-28
Built from http://hg.mozilla.org/mozilla-central/rev/895f66c4eada

Bad: 2012-09-29
Built from http://hg.mozilla.org/mozilla-central/rev/c09a0c022b2e

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=895f66c4eada&tochange=c09a0c022b2e

Could this be caused by painting changes triggered by the DLBI landing in some way?
I guess so but it's not clear why.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #4)
> I guess so but it's not clear why.

That's the extent of the investigation?  Mozilla has a budget in the hundreds of millions, but rendering text at the Fx 3.6 level of quality is out of reach?
This is now in TB 24.0 as well, 17.0 was normal, nice surprise.

What is the objection to fixing this?
Duplicate of this bug: 926023
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812871
You need to log in before you can comment on or make changes to this bug.