Closed Bug 828247 Opened 7 years ago Closed 7 years ago

Library downloads view does not show the end time for completed downloads

Categories

(Firefox :: Downloads Panel, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: mano, Assigned: mak)

References

Details

Attachments

(1 file, 3 obsolete files)

Library downloads view does not show the end time for completed downloads.

There are two problems here:
1) There's a bug in getStatusText that ignores the end time for session downloads. That's easy to fix.
2) We don't have the end time for past downloads, only the start time. I've no idea what we can do about this.
(In reply to Mano from comment #0)
> 2) We don't have the end time for past downloads, only the start time. I've
> no idea what we can do about this.

use the file last modified time?
Unfortunately sometimes people edit those .doc files they download. I think we'll just have to use the visit date for downloads done in past releases.
(In reply to Mano from comment #2)
> Unfortunately sometimes people edit those .doc files they download. I think
> we'll just have to use the visit date for downloads done in past releases.

fine, none of the solutions is perfect, so no strong feelings.
Depends on: 826991
I may look at this, we'll just have to hook up endTime once we have it.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attached patch patch v1.0 (obsolete) — Splinter Review
Attached patch patch v1.1 (obsolete) — Splinter Review
Attachment #700371 - Attachment is obsolete: true
Attachment #700624 - Flags: review?(mano)
don't need the dependency to fix this, they can be parallel
No longer depends on: 826991
Attached patch patch v1.2 (obsolete) — Splinter Review
Always use shortDate per IRC discussion (I'm going to file bug to find the time threashold in future)
fix missing breaks; in the switch!
Attachment #700624 - Attachment is obsolete: true
Attachment #700624 - Flags: review?(mano)
Attachment #700710 - Flags: review?(mano)
Comment on attachment 700710 [details] [diff] [review]
patch v1.2

Review of attachment 700710 [details] [diff] [review]:
-----------------------------------------------------------------

As a temporary solution, this is fine.

::: browser/components/downloads/content/allDownloadsViewOverlay.js
@@ +360,5 @@
>      }
>  
> +    // This is a not-in-progress or history download.
> +
> +    let stateLabel = ""

nit #1: missing semicolon. nit #2: remove the empty line.
Attachment #700710 - Flags: review?(mano) → review+
Attached patch patch v1.3Splinter Review
Attachment #700710 - Attachment is obsolete: true
Comment on attachment 700718 [details] [diff] [review]
patch v1.3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: incomplete ui
Testing completed (on m-c, etc.): m-i (merge pending)
Risk to taking this patch (and alternatives if risky): limited to the feature
String or UUID changes made by this patch: none
Attachment #700718 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0481a14279d3
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #700718 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on the latest Nightly and Aurora - the end time for completed downloads is now displayed in the Library Downloads View.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130128 Firefox/21.0 Build ID:20130128030943
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130128 Firefox/20.0 Build ID:20130128042018	

Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130128 Firefox/21.0 Build ID:20130128030943
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130123 Firefox/20.0 Build ID:20130128042018

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130128 Firefox/21.0	Build ID:20130128030943
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130128 Firefox/20.0	Build ID:20130128042018
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.