Ctrl-Q closes the browser on Linux

RESOLVED DUPLICATE of bug 52821

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 52821
5 years ago
5 years ago

People

(Reporter: gzankevich, Unassigned)

Tracking

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121120201233

Steps to reproduce:

Hit Ctrl-Q instead of Ctrl-W accidentally while having the close window confirmation dialog disabled.


Actual results:

The browser closed.


Expected results:

Ctrl-Q should not close the browser window. This is bad UX. It's a non-standard shortcut, it's extremely easy to hit it by mistake since Ctrl-tab is often used to switch tabs and Ctrl-W is used to close tabs.

Why not just stick to convention and let the OS handle the close window shortcuts? This problem is already solved and adding yet another shortcut to close the window adds nothing new, save for a headache.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 52821
You need to log in before you can comment on or make changes to this bug.