[B2G][PhoneNumberJS] Sending a SMS to a phone number with 6 wrong characters fail

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: borjasalguero, Assigned: borjasalguero)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: interaction [UX-P2])

(Assignee)

Description

5 years ago
Scenario:
- Send a SMS to a phone number with 6 characters ('abcdef' for example)
- After clicking 'Send' come back to 'Thread List'

Expected:
- The message is shown in the right thread
- New thread created to 'abcdef' its created


Currently:
- New thread with a wrong phone number it's created
- Message is not shown in the right thread (in fact is not retrieved).
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(Assignee)

Comment 1

5 years ago
gal: This is intentional. Alphanumeric dialing translates the characters into numbers. Google`s library does this as well. We translate first to numbers, and then check for a valid phone number. 6 digits are a valid phone number in that country, but not other length of strings. I think this is INVALID.
(Assignee)

Updated

5 years ago
Component: DOM: Device Interfaces → Gaia::SMS
Product: Core → Boot2Gecko
QA Contact: mbarone976
Thanks Andreas.

So there still is a problem in SMS as apparently we don't handle this correctly. So changing component.
(Assignee)

Updated

5 years ago
blocking-basecamp: ? → ---
Nominating if we want to support this in v1 (using characters to represent the numbers).
blocking-basecamp: --- → ?
Daniel, please check and renominate
blocking-basecamp: ? → -
Flags: needinfo?(dcoloma)
(Assignee)

Comment 5

5 years ago
Im gonna try to check if it has a quick fix or not. Assigning to me!
Assignee: nobody → fbsc
(Assignee)

Comment 6

5 years ago
Gregor, when Im retrieving the message created in Gecko in 'onSending' handler, the message is not the one that it's stored in Gecko (it's the one that I've typed, without phone number normalization). Do you know what it's happening there? Thanks!
Flags: needinfo?(anygregor)

Comment 7

5 years ago
i cannot reproduce this bug
request QA to test if it is still valid.
Whiteboard: interaction [UX-P2]
(In reply to Borja Salguero [:borjasalguero] (On Holidays until Monday 21th) from comment #6)
> Gregor, when Im retrieving the message created in Gecko in 'onSending'
> handler, the message is not the one that it's stored in Gecko (it's the one
> that I've typed, without phone number normalization). Do you know what it's
> happening there? Thanks!

I think this is because of bug 830335 and should be fixed in bug 823010.
Flags: needinfo?(anygregor)
Blocks: 833706

Updated

5 years ago
Flags: needinfo?(dcoloma)

Comment 9

5 years ago
try to reproduce in v1-train with following build info.

Gaia:     7ea7918013a012ddf04a1324592b898530488178
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/6a187d801193
BuildID   20130423070204
Version   18.0

Can't reproduce this issue. Please help to verify the bug remains, thanks.
Flags: needinfo?(fbsc)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Flags: needinfo?(fbsc)
You need to log in before you can comment on or make changes to this bug.