Closed Bug 828488 Opened 7 years ago Closed 7 years ago

Properly set the "active" attribute for session downloads

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed

People

(Reporter: mak, Assigned: mak, NeedInfo)

References

Details

Attachments

(1 file, 2 obsolete files)

The session downloads don't get the attribute and lack the binding.
Attached patch patch v1.0 (obsolete) — Splinter Review
Attachment #699890 - Flags: review?(mano)
Attached patch patch v1.1 (obsolete) — Splinter Review
better, per IRC discussion
Attachment #699890 - Attachment is obsolete: true
Attachment #699910 - Flags: review?(mano)
Attached patch patch v1.2Splinter Review
even better!
Attachment #699910 - Attachment is obsolete: true
Attachment #699910 - Flags: review?(mano)
Attachment #699921 - Flags: review?(mano)
cherry-picked the inbound patch to central, just to ensure it will make the next nightly.
there should be no problem on merge since they are identical.
https://hg.mozilla.org/mozilla-central/rev/f60b87eed1ac
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 699921 [details] [diff] [review]
patch v1.2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: Incomplete UI
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Limited to the feature
String or UUID changes made by this patch: none
Attachment #699921 - Flags: approval-mozilla-aurora?
Attachment #699921 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
How can QA verify this fix?
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.