Closed Bug 828507 Opened 7 years ago Closed 7 years ago

Firefox 19b1 Beta updates fail to apply

Categories

(Toolkit :: Application Update, defect, blocker)

19 Branch
All
Windows 8
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
Tracking Status
firefox19 + verified
firefox20 + verified

People

(Reporter: simona.marcu, Assigned: akeybl)

References

Details

Attachments

(2 files)

Updating to any beta on the "releasetest" and "betatest" channels is failing.

Tried to update Firefox 17 beta 6 and Firefox 18 beta 7 to Firefox 19 beta 1.

Steps to reproduce:
1. Install an older beta version (e.g. Firefox 17 beta 6 and Firefox 18 beta 7)
2. Change the channel update to "releasetest" or "betatest"
3. Open Firefox
4. Go to Tools menu-> About:Firefox 

Expected result:
The update is downloaded and the Apply updates button can be clicked.

Actual results:
The update is downloaded but instead of the Apply Update button the following message is displayed: Update failed. Download the latest version.
The update fails only on Windows. 
Works fine on Ubuntu and Mac.
Can you set app.update.log to true and paste the entries in the error console that start with AUS?
Attached file Betatest update log
Update log from 18.0b6 -> 19.0b1 en-US Win8 betatest
Here's more detail on the user experience:

1. Set update channel to betatest by editing channel-prefs.js
2. Start Firefox 18.0b6 with a new profile
3. Click the Help menu > About Firefox
> Firefox checks for and finds a partial update to 19.0b1
> Firefox downloads the partial update and attempts to apply it
> Firefox fails to apply it and automatically begins downloading a complete update
> Firefox attempts to apply the complete update
> Firefox fails to apply the complete update and displays "Update fails. Download the latest version" in the About dialog
Comment on attachment 699915 [details]
Betatest update log

What are the values for ACCEPTED_MAR_CHANNEL_IDS in your update-settings.ini file located in your installation directory?
Looks like MAR channel is not accepted. Have there been changes to this lately that landed on beta?

#define MAR_CHANNEL_MISMATCH_ERROR 22


that's the info info confvars.sh for ACCEPTED_MAR_CHANNEL_IDS is not matching what the MAR offered is which is built from the value of MAR_CHANNEL_ID.
(In reply to Robert Strong [:rstrong] (do not email) from comment #2)
> Can you set app.update.log to true and paste the entries in the error
> console that start with AUS?

You can find those entries in my attachment.
(In reply to Robert Strong [:rstrong] (do not email) from comment #6)
> What are the values for ACCEPTED_MAR_CHANNEL_IDS in your update-settings.ini

ACCEPTED_MAR_CHANNEL_IDS=firefox-mozilla-beta,firefox-mozilla-release
Meh... looks like release drivers went ahead with using aurora's confvars.sh eben though bug 818333 was backed out per bug 818333 comment 19 due to the channel not being set except when building the nightly now.
http://mxr.mozilla.org/mozilla-beta/source/browser/confvars.sh
I'm escalating this to blocker given we can't release until this is fixed.
Severity: normal → blocker
QA Contact: anthony.s.hughes
Summary: Beta update fails → Firefox 19b1 Beta updates fail to apply
Version: unspecified → 19 Branch
(In reply to Robert Strong [:rstrong] (do not email) from comment #10)
> Meh... looks like release drivers went ahead with using aurora's confvars.sh
> eben though bug 818333 was backed out per bug 818333 comment 19 due to the
> channel not being set except when building the nightly now.
> http://mxr.mozilla.org/mozilla-beta/source/browser/confvars.sh

We'd already changed our documentation, and didn't see that bug 818333 was re-opened/unassigned (or get email to that end).

This will need to be resolved on both Beta and Aurora, and will sadly require a beta re-spin.
Assignee: nobody → akeybl
Damn, thought you were reading bugmail. Perhaps changes to the merge document that rely on bugs should also be tracked in bugzilla and made a dependency of the bug that makes the change to avoid this in the future.
Ya seen the same as Comment 10 by inspecting the .mar file.
Marking this resolved fixed based on comment 17.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: verifyme
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130108132750

On the "betatest" channel the updates are properly done - the updates were done from Firefox 17 beta 6 and Firefox 18 beta 7 - on Windows XP, Windows 7, Windows 8, Ubuntu 12.10 and Mac OS X 10.7.

But Firefox 19b1 Beta updates still fail to apply on the "releasetest" channel (Firefox behaves as described in Comment 5). 
Is this expected in any way?
Reopening this bug based on Comment 19.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Simona B [QA] from comment #19)
> Firefox 19b1 Beta updates still fail to apply on the "releasetest"

This was because Firefox 19.0b1#2 builds were pushed to releasetest before spun 19.0b1#3. These updates have now been purged via bug 829038. Calling this resolved fixed and will verify via automation.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Depends on: 829038
Resolution: --- → FIXED
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #21)
> Calling this resolved fixed and will verify via automation.

Sorry, I forgot to update this bug. Updates have been working correctly for a while now.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.