The default bug view has changed. See this FAQ.

Cannot set custom properties on Typed Arrays

RESOLVED DUPLICATE of bug 695438

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 695438
4 years ago
3 years ago

People

(Reporter: ncoder2000, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.101 Safari/537.11

Steps to reproduce:

I am using typed arrays to map to WebGL vertex structures, and it is extremely convenient to store stride / offset values on the typed arrays. This works fine in Webkit.
var x = new Float32Array(1)
x.stride = 1
and then:
x.stride == undefined


Actual results:

Custom properties on typed arrays dont work


Expected results:

They should work because its makes it easy to keep important values such as vertex stride on the typed arrays. This way you can just pass around a typed array and util vertex generation code can use them without extra objects to keep these values.
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 695438

Updated

3 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.