Last Comment Bug 828799 - WebGL hardware acceleration under Linux is "0/1 Basic no information"
: WebGL hardware acceleration under Linux is "0/1 Basic no information"
Status: RESOLVED DUPLICATE of bug 594876
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 18 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 19:56 PST by Kai Hendry
Modified: 2013-01-14 02:27 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kai Hendry 2013-01-09 19:56:03 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

Loaded Banana Bread on two different Linux machines with GL/Mesa support


Actual results:

Poor performance, no hardware acceleration


Expected results:

3D accelerated Banana Bread.

http://s.natalian.org/2013-01-10/1357789605_1366x768.png - from Sandy bridge laptop
http://ix.io/3Ve - about:support from Ivy bridge
Comment 1 Matthias Versen [:Matti] 2013-01-10 07:13:12 PST
https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers
Comment 2 Joe Drew (not getting mail) 2013-01-10 08:55:26 PST
Your WebGL is hardware accelerated (see WebGL Renderer). However, because we don't have hardware accelerated display of content on Linux, we have to read it back from the GPU and display it using software. That's what the "0/1 Basic" means.

*** This bug has been marked as a duplicate of bug 594876 ***
Comment 3 Kai Hendry 2013-01-10 20:51:23 PST
Thanks Joe. Reading https://bugzilla.mozilla.org/show_bug.cgi?id=594876#c35 I had the impression it's fast. I'm getting 20FPS on Banana bread on an Ivy Bridge setup, which is pretty poor.

We need a better "sanity test" (acceleration on and off side by side would be nice) and a better indication of what's going (wr)on(g) that "0/1 Basic"... Should I file a new bug?
Comment 4 Joe Drew (not getting mail) 2013-01-11 12:11:45 PST
Nothing's wrong with your setup wrt accelerated windows; that's just indicating that you're not using OpenGL for composition, which is expected on Linux.
Comment 5 Kai Hendry 2013-01-14 02:27:49 PST
I don't quite understand. If I use "OpenGL for composition" (not sure functionality this exists), will that help accelerate Firefox performance?

Note You need to log in before you can comment on or make changes to this bug.