Closed Bug 828895 Opened 7 years ago Closed 7 years ago

keyboard navigation in the Library View is bogus

Categories

(Firefox :: Downloads Panel, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: mak, Assigned: mak)

References

Details

(Whiteboard: regression)

Attachments

(1 file, 2 obsolete files)

Paolo notified me pagedown makes lazy loading go mad, I also see a bunch of exceptions generated by ensureVisibleElementsAreActive.
Summary: keyboard navigation is bogus → keyboard navigation in the Library View is bogus
Attached patch patch v1.0 (obsolete) — Splinter Review
This looks like a simple coordinates problem, we have a rounded border on elements, richlistitems may have a top/bottom margin and likely there could be some subpixel rounding.

I implemented this solution to verify that theory and so far I didn't see the exception, though it's maybe not the most elegant thing we may do.
Attachment #700337 - Flags: feedback?(mano)
I wonder if we should just try with NodesFromRect
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment on attachment 700337 [details] [diff] [review]
patch v1.0

ok, let's try nodesFromRect and see if it's less bogus.
Attachment #700337 - Flags: feedback?(mano)
Attached patch patch v1.1 (obsolete) — Splinter Review
Attachment #700337 - Attachment is obsolete: true
Attachment #700576 - Flags: review?(mano)
Comment on attachment 700576 [details] [diff] [review]
patch v1.1

>+      // To ensure proper keyboard navigation we muse activate also the last
>+      // non-visible node and the first non-visible node.

I think this would read better:

"Also activate the first invisible nodes in both boundaries (that is, above and below the visible area)
 to ensure proper keyboard navigation in both directions."

>+      let nodeAfterVisibleArea = lastVisibleNode && lastVisibleNode.nextSibling;
...
>+      let nodeBeforeVisibleArea =
>+        firstVisibleNode && firstVisibleNode.previousSibling;

after->below, before->above.
Attachment #700576 - Flags: review?(mano) → review+
Attached patch patch v1.2Splinter Review
Attachment #700576 - Attachment is obsolete: true
Comment on attachment 700609 [details] [diff] [review]
patch v1.2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: incomplete ui
Testing completed (on m-c, etc.): m-i (merge pending)
Risk to taking this patch (and alternatives if risky): limited to the feature
String or UUID changes made by this patch: none
Attachment #700609 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7e4917d358c5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #700609 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 20 on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130326150557
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
You need to log in before you can comment on or make changes to this bug.