Closed Bug 828957 Opened 7 years ago Closed 7 years ago

Port |Bug 824330 - Enable services in xulrunner and don't build under services/ when building against a libxul SDK| to SeaMonkey

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.17 fixed)

RESOLVED FIXED
seamonkey2.18
Tracking Status
seamonkey2.17 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(1 file)

The patch in Bug 824330 should be ported to SeaMonkey/comm-central as otherwise (py)make will try to package mozilla/services/ twice (according to Neil).
OS: Windows XP → All
Hardware: x86 → All
Attached patch PatchSplinter Review
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Also the build will break locally when using pymake (looks like):
make.py[5]: Entering directory 'c:\mozilla\tree-hg\objdirs\seamonkey-objdir-debu
g-tests\mozilla'
Target 'services/Makefile' has multiple rules with commands.
[...]
e testing/mozbase/Makefile media/webrtc/signaling/test/Makefile media/mtransport
/test/Makefile' failed, return code 2
c:\mozilla\tree-hg\comm-central\mozilla\config\rules.mk:608:0: command 'c:/mozil
la-build/python/python.exe C:/mozilla/tree-hg/comm-central/mozilla/build/pymake/
pymake/../make.py export_tier_platform' failed, return code 2
Comment on attachment 700628 [details] [diff] [review]
Patch

Neil: See Attachment 698016 [details] [diff] for the Firefox patch, this patch ports the Firefox change to SeaMonkey. You also mentioned this on IRC yesterday afaik.
Attachment #700628 - Flags: review?(neil)
Attachment #700628 - Flags: review?(neil) → review+
Pushed: https://hg.mozilla.org/comm-central/rev/bc4fa652cdf7
Target Milestone: --- → seamonkey2.18
Comment on attachment 700628 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Some users may not be able to compile SeaMonkey; needed for comm-aurora as the underlying bug on mozilla-central landed before the uplift
Testing completed (on m-c, etc.): Works on comm-central, Firefox build.mk file was changed in the same way (this patch ports the change from Firefox to SeaMonkey)
Risk to taking this patch (and alternatives if risky): build change only, no risk
String changes made by this patch: -
Attachment #700628 - Flags: approval-comm-aurora?
Comment on attachment 700628 [details] [diff] [review]
Patch

a=me for comm-aurora
Attachment #700628 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed: https://hg.mozilla.org/releases/comm-aurora/rev/6eafbba68d75
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.