Closed Bug 828990 Opened 8 years ago Closed 8 years ago

Thumb position does not advance; and or, unnecessary thumb position in input fields on tap

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 22
Tracking Status
firefox20 --- wontfix
firefox21 --- fixed
firefox22 --- verified
fennec + ---

People

(Reporter: aaronmt, Assigned: bnicholson)

References

()

Details

Attachments

(1 file, 1 obsolete file)

Currently when one taps into an input field to focus it, a thumb position appears. Inserting characters into the field does not automatically advance the thumb position. 

I expected either the thumb position should advance, or otherwise not have it display at all.

--
Nightly (01/10)
Samsung Galaxy Nexus (Android 4.1.2)
I think we should hide the thumb if the user starts typing.
tracking-fennec: --- → ?
Version: unspecified → Trunk
Assignee: nobody → bnicholson
tracking-fennec: ? → +
This is now on Beta; silly imo
Attached patch Hide thumb on compositionend (obsolete) — Splinter Review
Hiding the thumb on compositionend seems to work fine from general testing - any edge cases that I should be aware of?

I also removed _elementReceivesInput and _isEditable since they appear to be dead code.
Attachment #726957 - Flags: review?(nchen)
CC'ing Margaret in case she has any feedback.
Comment on attachment 726957 [details] [diff] [review]
Hide thumb on compositionend

Err, sorry...didn't quite finish this yet.
Attachment #726957 - Flags: review?(nchen)
cleaned up
Attachment #726957 - Attachment is obsolete: true
Attachment #726991 - Flags: review?(jcheng)
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

Oops, wrong reviewer!
Attachment #726991 - Flags: review?(jcheng) → review?(nchen)
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

Review of attachment 726991 [details] [diff] [review]:
-----------------------------------------------------------------

Can someone else review this too? The patch looks okay to me, although I'm not familiar with browser.js

::: mobile/android/chrome/content/browser.js
@@ -4649,5 @@
>    },
>  
> -  _elementReceivesInput: function(aElement) {
> -    return aElement instanceof Element &&
> -        kElementsReceivingInput.hasOwnProperty(aElement.tagName.toLowerCase()) ||

I think you can remove kElementsReceivingInput too?
Attachment #726991 - Flags: review?(nchen) → feedback+
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

Yeah, I probably should have included margaret as a reviewer anyway -- just wanted to make sure the compositionend IME event will work as intended.
Attachment #726991 - Flags: review?(margaret.leibovic)
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

Review of attachment 726991 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Jim's right that you can get rid of kElementsReceivingInput.
Attachment #726991 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/af59a6b444f0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: thumb stays in fixed position when typing, which looks broken
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #726991 - Flags: approval-mozilla-aurora?
Status: RESOLVED → VERIFIED
Comment on attachment 726991 [details] [diff] [review]
Hide thumb on compositionend, v2

low risk, mostly clean-up - hides the thumb when you start inserting character in a input field.
Attachment #726991 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.