Closed Bug 829006 Opened 9 years ago Closed 9 years ago

Setting proxies via applyFilter() (nsIProtocolProxyFilter) does not work anymore when WPAD mode is selected

Categories

(Core :: Networking: HTTP, defect)

18 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox18 --- affected
firefox19 --- affected
firefox20 --- affected
firefox21 --- fixed

People

(Reporter: gk, Assigned: mcmanus)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file applyfilter.xpi
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0

Steps to reproduce:

I installed the attached minimal test-case which sets a non-existing proxy (127.0.0.1:9999) via applyFilter() in Firefox 18 and set the Firefox proxy settings to "Auto-detect proxy settings for this network".



Actual results:

The proxy in applyFilter() is ignored.


Expected results:

No connections should have been made as the proxy returned via applyFilter() is not existing.

Seems we missed that corner case in 795905.
OS: Windows 7 → All
Still an issue in Firefox 18.0.1. Blocking 769764 as this is likely caused by it (as 795905 has been).
Blocks: 769764
Assignee: nobody → mcmanus
Attached patch patch 0Splinter Review
the bug occurs when the pac thread is returning NOT_AVAILABLE (in the case of failed WPAD discovery in this case) we are going to go direct but instead we return the error to the HTTP (or other protocol stack) and let it do the mapping locally.

instead, lets make the -> direct map in the protocol proxy service and apply the filters and return OK to the protocol stack.
Attachment #705969 - Flags: review?(cbiesinger)
Comment on attachment 705969 [details] [diff] [review]
patch 0

biesi r? timeout resched
Attachment #705969 - Flags: review?(cbiesinger) → review?(jduell.mcbugs)
Attachment #705969 - Flags: review?(jduell.mcbugs) → review+
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/7d39a9c9cb7f
Target Milestone: --- → mozilla21
https://hg.mozilla.org/mozilla-central/rev/7d39a9c9cb7f
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Keywords: regression
You need to log in before you can comment on or make changes to this bug.