[traceback] KeyError: <class 'constants.applications.DEVICE_DESKTOP'>

VERIFIED FIXED in 2013-01-10

Status

Marketplace
Developer Pages
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Victor Carciu, Assigned: basta)

Tracking

({regression})

2013-01-10
x86_64
Windows 7
regression
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130109 Firefox/21.0

Steps to reproduce:
1.Go to MP-dev and log in with valid credentials
2.Go to Dev Hub and open an already submitted app
3.Go to "Compatibility & Payments" and change the compatible platform for the app
4.Press "Save changes" button

Expected results:
Platform is changed without any issue

Actual results:
"Oops.." message is displayed

Please see screencast for this bug :http://screencast.com/t/fzshc0HTx

NOTES:
Not reproducible in production

Comment 1

6 years ago
 File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "addons/decorators.py", line 33, in wrapper
    return f(request, addon, *args, **kw)
  File "amo/decorators.py", line 33, in wrapper
    return func(request, *args, **kw)
  File "mkt/developers/decorators.py", line 49, in wrapper
    return fun()
  File "mkt/developers/decorators.py", line 28, in <lambda>
    *args, **kw)
  File "mkt/developers/views_payments.py", line 57, in payments
    premium_form.save()
  File "mkt/developers/forms_payments.py", line 193, in save
    super(PremiumForm, self).save(self.addon, is_premium)
  File "mkt/submit/forms.py", line 63, in save
    mark_for_rereview(addon, added_devices, removed_devices)
  File "mkt/submit/forms.py", line 28, in mark_for_rereview
    for d in added_devices] +

sentry: KeyError: <class 'constants.applications.DEVICE_DESKTOP'>
Summary: "Oops.." message displayed when trying to change compatible platform. → [traceback] "Oops.." message displayed when trying to change compatible platform.

Comment 2

6 years ago
sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/10831/
Summary: [traceback] "Oops.." message displayed when trying to change compatible platform. → [traceback] KeyError: <class 'constants.applications.DEVICE_DESKTOP'>
(Assignee)

Comment 3

6 years ago
I tried but I can't reproduce this problem. What's the URL of the app that's failing?
(In reply to Matt Basta [:basta] from comment #3)
> I tried but I can't reproduce this problem. What's the URL of the app that's
> failing?
https://marketplace-dev.allizom.org/developers/app/test-app-applicationone/payments/
(Assignee)

Comment 5

6 years ago
Still can't repro :( :( :(

http://cl.ly/image/371I1l0h0E3g
(Assignee)

Comment 6

6 years ago
https://github.com/mozilla/zamboni/commit/5e872c6b95e59514983afd0aa6834734c5417b2e
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
Verified as fixed : http://screencast.com/t/ja34X5kkDw
Status: RESOLVED → VERIFIED
Assignee: nobody → mattbasta
You need to log in before you can comment on or make changes to this bug.