[traceback] SolitudeError: There was an error with that request. error when trying to add a Payment Account

VERIFIED FIXED in 2013-01-17

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: cboldan.mozbugs, Assigned: basta)

Tracking

2013-01-17
x86_64
Windows 7
Points:
---

Details

(Whiteboard: u=dev p=1)

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Load Compatibility & Payments page for an uploaded paid app (ex https://marketplace-dev.allizom.org/developers/app/test-app-subdomain-3/payments/ )
2. Click the "Add Account" button from the "Sell your app" section
3. Complete all the fields correctly
4. Click the "Register Payment Account" button

Expected results:
Account is added successfully.

Actual results:
Oops! error is displayed. Also, the field titles from the form goes over the error floating window, and user needs to close the whole form an re-enter all the data in order to try again.

Notes/Issues:
Verified on FF21 (Win 7).
Screencast for this issue http://screencast.com/t/cCR1bDCfR

Comment 1

6 years ago
Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 160, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 152, in wrapper
    return f(*args, **kw)
  File "amo/decorators.py", line 54, in wrapper
    return f(request, *args, **kw)
  File "amo/decorators.py", line 33, in wrapper
    return func(request, *args, **kw)
  File "mkt/developers/views_payments.py", line 148, in payments_accounts_add
    request.amo_user, form.cleaned_data)
  File "mkt/developers/models.py", line 93, in create_bango
    client.post_bank_details(data=bank_details_values)
  File "lib/pay_server/base.py", line 172, in wrapped
    return self.call(url, method, data=data)
  File "lib/pay_server/base.py", line 137, in call
    code=code)

sentry: SolitudeError: There was an error with that request.
Summary: Oops error is displayed when trying to add a Payment Account → [traceback] SolitudeError: There was an error with that request. error when trying to add a Payment Account
Target Milestone: --- → 2013-01-10
Assignee: nobody → mattbasta
Priority: -- → P1
Whiteboard: u=dev p=
Target Milestone: 2013-01-10 → 2013-01-17

Updated

6 years ago
Depends on: 829645
Whiteboard: u=dev p= → u=dev p=1
(Assignee)

Comment 2

6 years ago
It appears that this is happening within solitude. Here's a dump of the logs:

Jan 11 14:28:55 dev1: [] s:INFO POST /generic/seller/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:28:55 dev2: [] s:INFO POST /bango/package/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:28:57 dev1: [] s:INFO POST /bango/bank/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:30:08 dev2: [] s:INFO POST /generic/seller/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:30:08 dev1: [] s:INFO POST /bango/package/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:30:09 dev2: [] s:INFO POST /bango/bank/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:36:43 dev1: [] s:INFO POST /generic/seller/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:36:44 dev2: [] s:INFO POST /bango/package/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262
Jan 11 14:36:46 dev1: [] s:INFO POST /bango/bank/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:262


Basically, Solitude is getting all the way through the registration process and then failing on /bango/bank, but it isn't throwing a traceback (despite returning an error to the client).

Until we can see tracebacks from solitude, i don't think there's much we can do here to debug. See the dependency (bug 829645).
(Assignee)

Comment 3

6 years ago
This was caused by this:

https://github.com/mozilla/solitude/commit/0875827957f6d101180e888a00839747d5364615
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/ on FF21 (Win 7)
Postfix screencast http://screencast.com/t/9irpavXD
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.