[Spanish] CTRL+E launches Composer, instead of "selecting all" like on explorer windows

RESOLVED WONTFIX

Status

()

Core
Localization
--
enhancement
RESOLVED WONTFIX
17 years ago
13 years ago

People

(Reporter: Andrés G. Aragoneses, Assigned: Rose Smyth)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

I've observed that in Windows, when you're exploring a directory, you can press
CTRL+E to select all elements. I think it should be useful to give CTRL+E the
same function, but now in textareas on a web page. I mean, if you are on a text
area with some lines of text already written, why not pressing CTRL+E and seeing
all the text selected?

Reproducible: Always
Steps to Reproduce:
Go on a textarea. Press CTRL+E.

Actual Results:  Composer appears.

Expected Results:  All text is selected.

Comment 1

17 years ago
Wasn't that CTRL+A to "mark all" (this works in Mozilla, too)? CTRL+E means
"Edit this Message as New" in Mozilla.

Comment 2

17 years ago
Ctrl+E doesn't seem to do anything in Explorer that I can see.  It's definitely
Ctrl+A that's select all.

Comment 3

17 years ago
Marking INVALID as this is no bug: CTRL+A works fine and CTRL+E shouldn't do a
"select all".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

17 years ago
Ok guys, sorry for that. The thing is that I am using a Spanish version of
Windows Operating System, and the key combination changes, instead of CTRL+A it
is CTRL+E. I don't know why is CTRL+E because the word "all" in Spanish doesn't
begin with an 'E'.

Comment 5

17 years ago
all: my first response was to mark invalid, so please don't be offended.

reporter: I'm going to reopen and send to localization to ask that the 
spanish version consider using ctrl-e. In the future please try to report that 
you're using the spanish version of windows (even changing the User-Agent line 
in the bugreport from  en-US to es-<something>) would help.

fwiw, the english version of ie5.5 maps ctrl-e to toggle the search explorer 
bar.

Localization has a few options including marking: worksforme (if ctrl-e already 
does this), wontfix (.), invalid (please supply a reason), fixed (.).

I don't usually run w2k in a spanish mapping nor have i used navigator that 
way so i don't know anything about it.  I tried switching input locals for 
ie5.5[explorer not browser] and ctrl-e/ctrl-a behaved the same as en-US, except 
that it took me a while to find : and / -- I had to use the onscreen keyboard 
to find :
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Localization
Resolution: INVALID → ---
Summary: CTRL+E launches Composer, instead of "selecting all" like on explorer windows → [Spanish] CTRL+E launches Composer, instead of "selecting all" like on explorer windows

Comment 6

17 years ago
reassigning
Assignee: asa → rchen
QA Contact: doronr → andreasb
(Reporter)

Comment 7

17 years ago
Ok thanks for your comments.
Now I have found out that on Windows 2000 (es-ES) happens the same as on Windows
ME: CTRL+E selects all and CTRL+A appears not to have any functionality.

Comment 8

17 years ago
Don't know who owns Mozilla Spanish localization. 

Reassigned to Tao.
Assignee: rchen → tao

Comment 9

17 years ago
Changing status to New for now.

Daniel, Michelle - can you re-assign this to the correct engineers (QA +
Development) in case we can't get this fixed in the core build?  
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

17 years ago
reassigning
Assignee: tao → rsmyth
QA Contact: andreasb → pgorman

Comment 11

16 years ago
It's true. In windows Spanish edition CONTROL-E is "SELECT ALL".

Now my opinion: I'm spanish and I think we don't need to make an IE clone. Some
IE features are cool but we don't need to emulate all IE features. In spanish
"SELECT ALL" is "SELECCIONAR TODO" and CONTROL-E is not the first letter of any
spanish word. I think it's better to have the same shortcuts for the same
options whenever browser language we use.

So I vote to close this bug with DONTFIX
(Reporter)

Comment 12

16 years ago
Vicente, perhaps you are right. I am not sure yet if this is worth for Spanish
operating systems. I am Spanish also but I would not mark this bug as WONTFIX
until we hear some additional opinions.

Comment 13

13 years ago
Can anyone with a Spanish Mozilla check if this problem is still reproducable?
(In reply to comment #13)
> Can anyone with a Spanish Mozilla check if this problem is still reproducable?


Yes, and we (es-ES l10n team) won't fix it. We decided back when we took l10n on
Mozilla 1.0 that we would keep en-US keyboard shortcuts. In fact, it's just
Microsoft who insists in adapting shortcuts, which drives us crazy, because most
other localized software (for instance, Acrobat Reader or OpenOffice) use
[Ctrl]+[O] to open a file and [Ctrl]+[A] to select all, whereas Microsoft
products use [Ctrl]+[A] to open ("Abrir", in spanish) a file; that's why they
can't use [Ctrl]+[A] to select all.

This topic has been discused in netscape.public.mozilla.l10n newsgroup; it has
even been proposed to remove commandkeys from l10n files, in order to ensure all
localizations use the same keyboard shortcuts. More info here:

http://groups.google.es/group/netscape.public.mozilla.l10n/browse_thread/thread/df3affe36bd789aa/6e9299729a4dd42d?q=group:netscape.public.mozilla.l10n+insubject:Question+insubject:about+insubject:localizing+insubject:global+insubject:accelerator+insubject:keys&rnum=1&hl=es#6e9299729a4dd42d
(Reporter)

Comment 15

13 years ago
Thanks for your comment Ricardo.

Resolving to WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.