Closed Bug 829063 Opened 7 years ago Closed 7 years ago

Toolbox style improvements

Categories

(DevTools :: Framework, defect)

x86
All
defect
Not set

Tracking

(firefox20 fixed)

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed

People

(Reporter: paul, Assigned: paul)

Details

Attachments

(2 files, 2 obsolete files)

No description provided.
Attached patch v0.1 (obsolete) — Splinter Review
This patch correctly includes the noise (missing from jar.mn), implement the flat toolbar, and implement the correct design for the sidebar.

Not tested on Windows yet.
Attached image screenshot of patch on windows (obsolete) —
Looks awesome with an added advantage of having style upgrade for 2 of my add-ons automatically for free :P

Although the sidebar's selected tab is missing some style ...
Attached patch v1Splinter Review
windows aero preprocessing added
Assignee: nobody → paul
Attachment #700453 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #700477 - Flags: review?(fayearthur)
Attached image screenshot of patch v1
This is perfect. sidebar tab issue fixed now.
Attachment #700464 - Attachment is obsolete: true
Comment on attachment 700477 [details] [diff] [review]
v1

Review of attachment 700477 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. One small visual issue on Mac - the inspector sidebar's toolbar looks to be 1px higher than the breadcrumb's toolbar: http://i.imgur.com/AEU5w.png.

::: browser/themes/pinstripe/devtools/splitview.css
@@ +68,5 @@
>  
>  /* Toolbars */
>  
>  .devtools-toolbar {
>    height: 26px;

jw, is this obsolete now?
Attachment #700477 - Flags: review?(fayearthur) → review+
(In reply to Heather Arthur [:harth] from comment #5)
> Looks good. One small visual issue on Mac - the inspector sidebar's toolbar
> looks to be 1px higher than the breadcrumb's toolbar:
> http://i.imgur.com/AEU5w.png.

That's bad :( That means I'm missing something in my padding computation.
I don't have this problem on my Mac.

> ::: browser/themes/pinstripe/devtools/splitview.css
> @@ +68,5 @@
> >  
> >  /* Toolbars */
> >  
> >  .devtools-toolbar {
> >    height: 26px;
> 
> jw, is this obsolete now?

It's in splitview.css. I don't want to touch this yet.
(In reply to Paul Rouget [:paul] from comment #6)
> (In reply to Heather Arthur [:harth] from comment #5)
> > Looks good. One small visual issue on Mac - the inspector sidebar's toolbar
> > looks to be 1px higher than the breadcrumb's toolbar:
> > http://i.imgur.com/AEU5w.png.
> 
> That's bad :( That means I'm missing something in my padding computation.
> I don't have this problem on my Mac.

I will fix that later: bug 830684.
Whiteboard: [land-in-fx-team]
Comment on attachment 700477 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (toolbox)
User impact if declined: the inspector sidebar looks unfinished
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low (only CSS improvements)
String or UUID changes made by this patch: no
Attachment #700477 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/4ba4e660de74
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Attachment #700477 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [land-in-aurora]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.