Redirect /firefox/new fx latest users to /firefox/fx/#desktop

RESOLVED WONTFIX

Status

www.mozilla.org
Bedrock
P1
normal
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: cmore, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=dev c=redirect p=1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Web analytics data on Mozilla.org confirmed that users running the latest version of Firefox are very often downloading the latest version of Firefox. Most of the time, the latest version of Firefox is the most visited browser (or all browsers!) downloading Firefox from /firefox/new/. This is causing a lot of additional bandwidth and time taken from the end-user perspective re-downloading Firefox. We also should educate users that they don't need to keep re-downloading Firefox.

We've talked to metrics and they see the same thing in their data and they also believe that end users do not know that silent updates exist. 

I propose that we redirect users from:

www.mozilla.org/[locale]/firefox/new/

to:

www.mozilla.org/en-US/firefox/fx/#desktop


How are users landing on /firefox/new?


* They are searching for firefox and /firefox/new/ has high SEO and thus get land on a page made for non-Firefox or old versions of Firefox. Some users are going to firefox.com, but that doesn't exist in search engines because it is a 301 redirect and not a real website.

Why should we redirect users to /firefox/fx/?

Because:

* /firefox/fx/#desktop checks to see if you are running the latest version.
* /firefox/fx/ also promotes mobile 
* /firefox/fx/ also allows users to re-download a fresh copy of Firefox if they desire.

/firefox/fx/ exists for other locales and need to make sure #desktop is at the end of the URL regardless of the locale. For en-US, this will display the desktop tab, for other locales, it will not hurt anything as there is only a single /fx/ scene.

Comment 1

6 years ago
+1 -- this will provide a much stronger user experience!
(Reporter)

Comment 2

6 years ago
Created attachment 701891 [details]
Firefox downloading Firefox graph

As predicted, Firefox 18 is the latest version of Firefox downloading Firefox 18.
(Reporter)

Comment 3

6 years ago
Oh, this past week, Firefox 18 is being download by Firefox 18 more than any other browser.
(In reply to Chris More [:cmore] from comment #3)
> Oh, this past week, Firefox 18 is being download by Firefox 18 more than any
> other browser.

Marketing needs to run a promo / snippet to explain the auto update process to users
(Reporter)

Comment 5

6 years ago
(In reply to raymond [:retornam] from comment #4)
> (In reply to Chris More [:cmore] from comment #3)
> > Oh, this past week, Firefox 18 is being download by Firefox 18 more than any
> > other browser.
> 
> Marketing needs to run a promo / snippet to explain the auto update process
> to users

Yup. I've alerted people to this issue and we will try to have an upcoming communication explaining this. Possibly an about:home snippet.
(Reporter)

Comment 6

6 years ago
I talked to Winston and Carmen and they are doing some upcoming user engagement updates on this very issue.

Updated

6 years ago
Whiteboard: u=dev c=redirect p=1
(Reporter)

Comment 7

6 years ago
pmac: Will this logic be possible in your redirect app? Specifically, to be able to redirect users running the latest version of Firefox release channel to be auto redirected from /firefox/new/ to /firefox/fx/#desktop ? The #desktop to important to keep in the redirect since it goes to the desktop tab of the existing user pages.
Priority: -- → P1
(Reporter)

Comment 8

6 years ago
Now that the /firefox/new/ page is live, we should see what it would take to make this redirect intelligent so that people running the latest version are redirected, but no one else.

Updated

5 years ago
Blocks: 879544

Updated

5 years ago
Depends on: 883801
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 9

5 years ago
I am going to WONTFIX my own bug because the unified firefox download in bug 868199 will deprecate the need for /firefox/fx/ page.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.