Closed Bug 829384 Opened 8 years ago Closed 8 years ago

Menus broken on http://demo.rockettheme.com/may11/?presets=preset4 due to MooTools 1.2.5

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: epinal99-bugzilla2, Unassigned)

References

()

Details

(Keywords: regression)

Bug created from comment https://bugzilla.mozilla.org/show_bug.cgi?id=828326#c11

STR:
Open http://demo.rockettheme.com/may11/?presets=preset4

Result: menus are broken, text "blurry".

The website is bad rendered because it's using MooTools 1.2.5 which is broken by adding String.prototype.contains (bug 789036).
The webmaster needs to update MooTools to version 1.3 or 1.4.
Blocks: 789036
Keywords: regression
@All

Also the whole slideshow doesn't display, the RokNewsPager module is completely expanded and it's supposed to be consolidated in an accordion style fashion. If you click it's buttons it doesn't continue to next articles. So forth and so on.
Just update the outdated MootTools version you're using.
@Loic

Looking into it now. Thanks :-)
Fixed now.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
@Benjamin

You want to describe what you did to exactly fix your issue big guy. I'm pretty sure the world would like to know???
Sorry. If I do a hard reload, the menus look okay to me. Is this not the case for you? Maybe I don't understand what the website is supposed to look like.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
@Benjamin

You're right the problem has been fixed.

Let me go back and explain a little. This report was created based on a problem that a Rockettheme template was having. I'm not Rockettheme but I had the same exact problem, so I used a link to their demo to show an example of what the problem was.

I thought you responded as Rockettheme saying that you fixed the problem and I wanted to know what that particular fix was.

I was told by @Loic that the solution was to just update Mootools. Ha ha... But I have a Joomla site and "to just update Mootools" seems to be harder than levitating myself to the sun and roasting marshmallows.

Currently I've found a fix to load my site but I still keep getting a spinning wheel in the FF18 browser window tab that never finishes which caused me to have to replace some modules on my homepage due to non-completed display issues. My site is SevereTech.com. If you guys have a solution for the spinning wheel issue please share. Right now I don't know if it's related to the same mootools issue.
Okay, so this particular issue is resolved. I don't have any problem loading http://severetech.com. If you're problem continues, feel free to file another bug with appropiate steps to reproduce.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.