Assertion failure: "AncestorHasDirAuto set on node but not its children" with non-HTML element

RESOLVED FIXED in Firefox 20

Status

()

Core
DOM
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: smontagu)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
mozilla21
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox20 fixed, firefox21 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 700852 [details]
testcase (asserts fatally when loaded)

Assertion failure: !aElement->AncestorHasDirAuto() || child->AncestorHasDirAuto() (AncestorHasDirAuto set on node but not its children), at content/base/src/DirectionalityUtils.cpp:688
(Assignee)

Comment 1

5 years ago
Created attachment 701785 [details] [diff] [review]
Make DoesNotParticipateInAutoDirection return true for non-HTML elements; and make WalkDescendantsSetDirAuto consistent with SetDirOnBind
Assignee: nobody → smontagu
Attachment #701785 - Flags: review?(ehsan)
(Assignee)

Comment 2

5 years ago
Created attachment 701786 [details] [diff] [review]
The testcase for checkin

Updated

5 years ago
Attachment #701785 - Flags: review?(ehsan) → review+

Comment 3

5 years ago
Comment on attachment 701786 [details] [diff] [review]
The testcase for checkin

rs=me
Attachment #701786 - Flags: review+
(Assignee)

Updated

5 years ago
Blocks: 830098

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/af13d04d949e
https://hg.mozilla.org/mozilla-central/rev/5d19aad2dab3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(Assignee)

Comment 6

5 years ago
Comment on attachment 701785 [details] [diff] [review]
Make DoesNotParticipateInAutoDirection return true for non-HTML elements; and make WalkDescendantsSetDirAuto consistent with SetDirOnBind

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 548206 or one of it's follow-ups
User impact if declined: possible incorrect resolution of elements with dir=auto
Testing completed (on m-c, etc.): Baked on m-c since 2013-01-15
Risk to taking this patch (and alternatives if risky): None known
String or UUID changes made by this patch: None
Attachment #701785 - Flags: approval-mozilla-aurora?
Attachment #701785 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Backed out as this set the tree on fire.

https://hg.mozilla.org/releases/mozilla-aurora/rev/edd364a9f0d5
status-firefox20: fixed → ---
status-firefox21: fixed → ---
status-firefox20: --- → affected
status-firefox21: --- → fixed
(Assignee)

Comment 10

5 years ago
Created attachment 708472 [details] [diff] [review]
The patch merged to Aurora

Yeah, Aurora doesn't have bug 828166 so the trunk patch doesn't build there.

Comment 12

5 years ago
Hi !
Can occitan language be added on :
http://hg.mozilla.org/releases/mozilla-aurora/file/tip/browser/locales/shipped-locales
and
http://www.mozilla.org/en-US/firefox/all-aurora.html

Files are availables on http://mozilla.locamotion.org/oc/firefox/

Best regards
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

5 years ago
Comment 12 has nothing to do with this bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Keywords: regression
Issue reproducible with the debug build from 2013-01-10. (assertion failure + Firefox crash)

Verified fixed with Firefox 21 latest debug build, on Mac OSX 10.8.3 (no assertion failure + no Firefox crash)

Build ID: 20130426142004
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.