Closed Bug 829563 Opened 7 years ago Closed 7 years ago

Slow/frozen (Live Bookmark) RSS feeds in FF18

Categories

(Firefox :: Bookmarks & History, defect)

18 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 832641

People

(Reporter: walter.iandolo, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

Update from FF17 to FF18


Actual results:

The RSS feed bookmarks ("live bookmarks") load fast the first few seconds and from then start slowing down to a crawl. Other Browsers' function seem unaffected.

The problem does not occur if FF is started in safe mode.
The problem DOES occurr if there are no add-on installer, or if all add-ons are disabled.

I have also performed a reset (which eliminates all add-ons) and the issue persists as long as FF is started in "normal" mode.


Expected results:

No change compared to FF17. This behavior is clearly not intendedd.
The problem can be reproduced: it happens all the times.
Reboting the PC does not help.
Could you test the basic troubleshooting steps, please:

1) safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Do you still observe the slow RSS feeds?
Flags: needinfo?(walter.iandolo)
Summary: Slow/frozen RSS feeds in FF18 → Slow/frozen (Live Bookmark) RSS feeds in FF18
1) Safe mode: no issue

2) New profile: no issue so far (no Add on installed, Sync not yet enabled)

3) Old profile + reset: slow RSS

4) Old profile + all Add on disabled: slow RSS

Do you want me to try more combinations (e.g.: setup sync on the new profile? Install add ons?

Thanks!
Flags: needinfo?(walter.iandolo)
If it's normal in safe mode, so the culprit is one of your add-ons or the hardware acceleration.

Try to disable add-ons one by one and test.

For HWA, make a test with HWA disabled (see http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration)
Any feedback of the culprit add-on, please?
Flags: needinfo?(walter.iandolo)
Hi Loic,

honestly, I don't think it is an add-on issue.
When you do reset a profile, all Add-Ons are removed. The issue persisted.
Also, I created a new profile (no issue) and added the same add-ons, and I still don't have any issue.

It must be something related to sync OR to some of the specific bookmarks that I have. I have not had the chance to setup sync (the Sync config doesn't work between two accounts on the same machine - apparently, which makes it non-trivial).
Flags: needinfo?(walter.iandolo)
Attached file Bookmarks for test case (obsolete) —
Hi again.
I have been using FF18 for a few more days, switching between a newly created profile WITH add on and a "clean", newly created profile.
I have some observations, which are totally subjective, but -I hope- they help.

1) The "clean" profile is definitely faster, BUT I still see a noticeable delay compared to FF17 (and earlier versions).
I have attached the exported bookmarks. You will see a "live" folder in the bookmarks toolbar ("Barra de herramienta de marcadores" ... in Spanish).
Even after the live bookmarks have been loaded, there's a distinct delay while going through the various folders. It is not huge, but it is noticeable, and -at least for me- bothersome.

2) I have also made a trial with only few RSS folders. The delay is not noticeable. 

Comment regarding 1) and 2): it's as if the RSS process was changes somehow and got much less efficient, although it doesn't seem to be clogging the CPU (as it happened back in the days when FF3.1 was released: see bug 329534). Perhaps it is checking more often for updated RSS and there are more activities/tasks done prior to render the list of existing RSS bookmarks, and this gets worst when you have more bookmarks.

3) In the new profile with add-ons (Ghostery, Adblock Plus, Flashblock) the RSS is even slower. Not as bad as in my original account (which was totally unusable), but definitely bad.
And it does not get better if I disable, or reset the account. It's as if an add-on somehow changes, or affects the way FF handles RSS and slows it down "permanently".

There isn't anything solid here, I realize that, but I hope this helps.
Thanks for the help anyway.
Attachment #702164 - Attachment is obsolete: true
Walter, does your problem reproduce even with the HWA disabled?
Component: Untriaged → Bookmarks & History
Hi Manuela. No, disabling HW Acceleration does not seem to help.
Just to be sure: I have only changed the gfx.direct2d.disabled (set to "True" to disable HWA). If there's something else I should try, just let me know.

I am going to try to do some video grab to show the issue.
you can disable hwa from Options / Advanced / General
Hello Marco. Reading the description of bug 812904 it looks possibly the same, except I don't see the high CPU usage. I tried again with the task manager set of Fast refresh and the CPU was never maxed out.

I see on bug 812904 quite a lot of detailed logs and data. I wouldn't know how to generate it myself, but if it would help, and somebody explains me how to do it, I'll be happy to help.
I have just disabled HWA as indicated by Marco and the problem looks solved (!).
The behavior is the same as FF17 (subjectively).
Depends on: 794246
Well, thank you all for the help: this was great. My FF is usable again and it seems that a proper patch is on its way. That's just the best support ever: amazing.
Please retest on nightly to see if bug 794246 fixed this.
Depends on: 830697
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:21.0) Gecko/20130109 Firefox/21.0
Build ID: 20130109030942

This is reproduceble with or without Hardware Acceleration on Nightly 21.0a1. 
And if the menu bar is active then when scrolling with the mouse from File, Edit, View, Bookmarks, Tools, Help the pop-ups are slowed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 832641
Following bug 832641 fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 832641
Hi, I have been using FF19 for a few days now.
I have re-activated the HW acceleration and I no longer see the issue.
Thanks again to everyone who contributed.

I am marking the status as "Verified": I hope it's OK.
If there's anything else I should do, please let me know.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.