FF 18.0 no click event on transform'ed element with overflow-y:scroll child

RESOLVED DUPLICATE of bug 829921

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 829921
6 years ago
6 years ago

People

(Reporter: Dmitry, Assigned: mattwoodrow)

Tracking

({regression})

18 Branch
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox18 wontfix, firefox19- fixed, firefox20- fixed, firefox21- fixed)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.101 Safari/537.11

Steps to reproduce:

I have rather complicated html structure, where transform and overflow-y:scroll properties are present. I also have a click listener on a div which works perfectly in FF 17.0.1 and is broken in FF 18.0.0.

You can see everything here: http://jsfiddle.net/turbokuzmich/DYmKJ/

When I click on a word I expect "a" to be alerted. When the box is not scrolled everything is fine both in FF 17.0.1 and in FF 18.0. But when I scroll down at least 20px and click on a word in FF 18.0 click event is not triggered. FF 17.0.1 works correctly.


Actual results:

Clicking on a word does not alert "a" when the box is scrolled down.


Expected results:

Clicking on a word should alert "a" in all cases.
(Reporter)

Updated

6 years ago
Last good nightly: 2012-09-16
First bad nightly: 2012-09-17

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=3f0587ce1774

I will bisect to be sure which checkin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f7c89de3ab43
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120915201302
Bad:
http://hg.mozilla.org/mozilla-central/rev/b3f462d96fb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916161603
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=b3f462d96fb5


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/33087122ace7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916022601
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ee831a85d12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916033402
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33087122ace7&tochange=6ee831a85d12

Suspected: Bug 788044
Blocks: 788044
Component: Untriaged → Layout
Keywords: regression
OS: Mac OS X → All
Product: Firefox → Core
Bug 827577 does not affect this...
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
Just for the record:
Due to skipped revisions, the first bad revision could be any of:
changeset:   107173:0ee3959754f8
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Thu Sep 13 12:32:53 2012 +1200
summary:     Bug 788044 - Make various functions take const parameters. r=roc

changeset:   107174:6ee831a85d12
user:        Matt Woodrow <mwoodrow@mozilla.com>
date:        Sun Sep 16 22:32:59 2012 +1200
summary:     Bug 788044 - Make transformed frames the reference frame for their
display list tree. r=roc
Assignee: nobody → matt.woodrow

Updated

6 years ago
status-firefox18: --- → wontfix
status-firefox19: --- → affected
status-firefox20: --- → affected
status-firefox21: --- → affected
tracking-firefox19: ? → +
tracking-firefox20: ? → +
tracking-firefox21: ? → +
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829921
Not tracking as and marking this as fixed as the DUP is tracked and resolved fixed
status-firefox19: affected → fixed
status-firefox20: affected → fixed
status-firefox21: affected → fixed
tracking-firefox19: + → -
tracking-firefox20: + → -
tracking-firefox21: + → -
You need to log in before you can comment on or make changes to this bug.