Pref for "Compact folders when it will save over 100 kb" is not remembered

VERIFIED FIXED in mozilla0.9.2

Status

P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Peter, Assigned: dianesun)

Tracking

Trunk
mozilla0.9.2
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Request R&SR)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9+) Gecko/20010527

Pref for "Compact folders when it will save over 100 kb" is not remembered

When i set the above pref for my newsgroups, the checkbox is not retained upon
return to the pref.
(Reporter)

Comment 1

18 years ago
cc'ing stephen because he may be involved with fixing this.
Keywords: 4xp, correctness, mozilla0.9.1
(Reporter)

Comment 2

18 years ago
Stephen, could you add diane sun to the CC of this bug? I don't know her email
address.

Comment 3

18 years ago
Reassigning to Diane, cc'ing interested parties. Also, the actual compaction
code is not written - that's bug 17204.  This bug is for making sure the pref
gets remembered.
Assignee: sspitzer → dianesun

Updated

18 years ago
QA Contact: esther → gchan
(Assignee)

Comment 4

18 years ago
This preference is actually moved to preference dialog. See bug 79554

*** This bug has been marked as a duplicate of 79554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
NO, it's not a dupe. The other bug is about differentiating between compaction
settings for *different accounts". This bug is about remembering the setting at all.

reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

18 years ago
Changing status to New.
I see this in the current branch build
2001-06-07-13-0.9.1/ on Windows nt 4.0

Hopefully bug will be fixed (ie pref will be remembered)
as result of the new implementation of the pref in bug 79554.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 7

18 years ago
This was due to the changes in am-offline.xul  version 1.2.  
There are two duplicate ids with the same name for imap and nntp  which caused 
the preference not saved. 
The same with "Do not download message locally that are larger than "

Comment 8

18 years ago
PDT+ per 6/12 mtg.
Whiteboard: [PDT+]
(Assignee)

Comment 9

18 years ago
Created attachment 38489 [details] [diff] [review]
Fix for preference
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] Request R&SR
(Assignee)

Comment 10

18 years ago
This preference has been moved the global pref space : Edit -> Preference 
->Offline and Disk Space.  And it will not be affacted by the two ids with the 
same name but for IMAP,  POP seperately  in am-offline.xul  ver 1.2 
I'm confused.  I don't see offlineCompactFolder or offlineCompactFolderMin
elements in pref-offline.xul




Comment 12

18 years ago
So, the master patch is in bug 79554 (infact includes this patch too). Get'em 
in.

r=bhuvan 

Comment 13

18 years ago
I agree..it's little bit confusing until you trace to the patch in the bug 
79554.

Diane, Please post patch(es) in the entirety in the future. thanks.

bhuvan
in the future, if you've got a bug with the "master" patch, there is no need to
re-attach the same patch to other bugs.  (just indicate where the real patch lives.)

I've made comments to #79554, but those comments do not apply to this part of
the patch.

trusting bhuvan's review, sr=sspitzer

Comment 15

18 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
Blocks: 83989
(Assignee)

Comment 16

18 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
Commercial builds
2001-06-21-09-trunk/ WinNT 4.0
2001-06-21-11-trunk/ Linux 2.2, red hat 7.0
2001-06-21-08-trunk/ MAC 9.0.4

Note: Compact Folders pref was moved from an individual account basis
  to the Global pref section: Edit|Preferences| Offline & Disk Space
  See Bug 79554.

Note: Compact folders back end code is not implemented yet: bug 17204

Verified that the compact folders pref can be edited and/or saved.
Tried testing it in various windows (Browser, Composer, Messenger, etc..)
and it works fine.

Marking as Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.