Closed Bug 829870 Opened 7 years ago Closed 7 years ago

Appear the non-expected color gap on window that are opened from private one.

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 + verified
firefox21 + verified

People

(Reporter: tetsuharu, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #827938 +++

[Environment]
* Nightly 21, http://hg.mozilla.org/mozilla-central/rev/dccab70d8554
* OSX 10.8

[STR]
Open error console or popup window from the private browsing window.

[Result]
Please see screenshot (from Bug 827938).

This may be fixed if 827938 will fixed.
Hmm, turns out that macBrowserOverlay.xul is used in console.xul, and that triggers a call to nonBrowserWindowDelayedStartup which calls gPrivateBrowsingUI.init() which triggers the drawintitlebar attribute to be set: <http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#6941>.
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #701606 - Flags: review?(gavin.sharp)
No longer depends on: 827938
Attachment #701606 - Flags: review?(gavin.sharp) → review+
Blocks: PBnGen
Comment on attachment 701606 [details] [diff] [review]
Patch (v1)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 749394
User impact if declined: See comment 0
Testing completed (on m-c, etc.): Locally
Risk to taking this patch (and alternatives if risky): minimal risk.
String or UUID changes made by this patch: none.
Attachment #701606 - Flags: approval-mozilla-aurora?
Attachment #701606 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 830245
https://hg.mozilla.org/mozilla-central/rev/11b7a6a6bc4c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

Verified fixed on Firefox 20 beta 6 (Build ID: 20130320062118).
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

Verified fixed on Firefox 21 beta 2 (Build ID: 20130408165307).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.