If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

MailNews Core
Feed Reader
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: Jone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 2013010500

Steps to reproduce:

Import OPML file from Opera browser. This file contain sub-elements/ subfolder, for example:

<outline text="text" title="title" >
<outline text="text1" title="title1" type="rss" xmlUrl="url1" />
<outline text="text2" title="title2" type="rss" xmlUrl="url2" />
</outline>

(Thunderbird 17.0.2 Linux)


Actual results:

Sub-elements (subfolders) have not been imported and imported entries not have source url.

Comment 1

5 years ago
I think I've seen comments in the Feed reader code this is not yet supported. Alta88, is this still the case? Is this a dupe of something?
Component: Migration → Feed Reader
Product: Thunderbird → MailNews Core

Comment 2

5 years ago
opml import was fixed in Tb15 to support sub outlines, for Tb imports/exports.  if it's not working, the entire opml should be attached, though that snippet looks like it should work.
(Reporter)

Comment 3

5 years ago
Created attachment 702359 [details]
example (complete opml file)

This is a little example (opera-newsfeeds.opml): one newsfeed and one folder with two newsfeed. In Thunderbird I get only two entries and 0 folder.

Comment 4

5 years ago
this works exactly as intended, for me, using Tools->Import into a new feeds account.  the result is 2 folders in the new account (in folderpane); the first has 1 feed, the second has 2 feeds.  you can see this in Subscribe..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

5 years ago
ls <profile dir>/Mail/Feeds/

feeditems.rdf  Liferea - News      msgFilterRules.dat  OS.msf  Trash.msf
feeds.rdf      Liferea - News.msf  OS                  Trash
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 6

5 years ago
Created attachment 702670 [details]
view folders pane after import

Comment 7

5 years ago
as i said, that is all as expected.  what is the bug?
(Reporter)

Comment 8

5 years ago
0 folders in folders panel after import source with subfolders is Ok?? Hmm.. this behavior is not typical for any RSS aggregator.

Comment 9

5 years ago
you don't seem to understand that the rss icon in a folderpane feed account indicates a folder.  a feed folder may have 0, 1, or many feed subscriptions attached to it, which structure is better shown in the Subscribe dialog.  if there were a 2 level nesting in the opml, the folderpane item would have an a twisty, indicating subfolders.
(Reporter)

Comment 10

5 years ago
It's a feature? Sorry, but this is just bad design.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INVALID

Comment 11

3 years ago
Created attachment 8468268 [details]
thunderbirdnewsadapter.jar

Small Java tool to convert standard OPML files into OPML files where each news feed is put into it's own folder to maintain the folder structure in thunderbird as it was in the exporting newsfeed reader.

Example Usage:
java -jar thunderbirdnewsadapter.jar ./akregator-export.opml

Comment 12

3 years ago
Comment on attachment 8468268 [details]
thunderbirdnewsadapter.jar

Small Java tool to convert standard OPML files into OPML files where each news feed is put into it's own folder to maintain the folder structure in thunderbird as it was in the exporting newsfeed reader.

Example Usage:
java -jar thunderbirdnewsadapter.jar ./akregator-export.opml
You need to log in before you can comment on or make changes to this bug.