Camera crashes when switch repeatedly between video and camera mode

RESOLVED DUPLICATE of bug 827833

Status

Firefox OS
Gaia::Camera
--
critical
RESOLVED DUPLICATE of bug 827833
5 years ago
5 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash], crash signature)

(Reporter)

Description

5 years ago
I'm experiencing a crash with B2G 1.0.0-prerelease 18.0 2013011007021. If I keep switching back and forth between video and camera mode, I eventually hit a black screen and the phone reboots. It usually reproduces after 5 or so switches back and forth.

Stephen Donner was able to provide a crash report:
https://crash-stats.mozilla.com/report/index/2bac1e9d-9278-4815-ac59-8d44b2130112

Comment 1

5 years ago
It looks like bug 827833.
Severity: normal → critical
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | mozilla::layers::PImageContainerChild::FatalError]
Keywords: crash
Whiteboard: [b2g-crash]
Thanks for filing - I agree this a dupe of Bug 827833. I believe there are a few fixes left to land related to some of the camera issues that may address this crash.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827833
You need to log in before you can comment on or make changes to this bug.