Session is lost when opening Firefox via "New private window" jump list task

RESOLVED DUPLICATE of bug 829568

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 829568
6 years ago
6 years ago

People

(Reporter: D. A., Unassigned)

Tracking

({dataloss})

21 Branch
x86_64
Windows 7
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130112 Firefox/21.0
Build ID: 20130112030947

Steps to reproduce:
1. Open Nightly, load a few web sites in new tabs and windows.
2. Pin Nightly to the taskbar.
3. Click the "Nightly" main menu button, choose "Exit".
4. Right click the pinned Nightly icon on the taskbar, choose "New private window".
> A new private window appears.
5. Click the "Nightly" main menu button, choose "New Tab" -> "New Window"
> A new regular window appears.
6. In the regular window, visit about:sessionrestore


Actual results:
The previous non-private session is completely lost.

Expected results:
The previous non-private session should remain.
(Reporter)

Updated

6 years ago
Keywords: dataloss
(Reporter)

Comment 1

6 years ago
Excuse me - I kept overlooking the second bug report mentioned in the comments of bug 806137
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829568
You need to log in before you can comment on or make changes to this bug.