Can't delete a bookmark added to the homescreen and can't delete an everything.me app added to the homescreen

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: crdlc)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm guessing the root cause of this both bugs (everything.me app and bookmark on homescreen) is probably the same, so I'm filing one bug.

Steps:

1. Either add a bookmark to the homescreen or add an everything.me app to the homescreen
2. Hold the home button to enter edit mode
3. Try deleting the bookmark or everything.me app you added

Expected:

You should be able to delete it.

Actual:

You can't delete it. Restarting the phone also won't remove it, so once you add a bookmark or everything.me app to the homescreen, then you'll never get rid of it.

In other words - a very bad regression we need to block on.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
Keywords: regression
(Reporter)

Comment 1

5 years ago
Oh and build info:

Device: Unagi
Build: B2G 18 1/12/2013

Hashes:

  <project name="releases/gecko.git" path="gecko" remote="mozillaorg" revision="3ce75653635cdeae69253320e45157171544c596"/>
  <project name="releases/gaia.git" path="gaia" remote="mozillaorg" revision="df38c1bb813029f3ccfa4a997fb1529b3ff1a1ff"/>
(Reporter)

Updated

5 years ago
Duplicate of this bug: 830255
(Assignee)

Comment 3

5 years ago
Regression:

https://github.com/mozilla-b2g/gaia/commit/67328ae8f39934039726ae0c8fc0348658d58c6f
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Reporter)

Comment 4

5 years ago
I had a strong feeling bug 820206 broke this :(, but thanks for confirming.
Blocks: 820206
(Assignee)

Comment 5

5 years ago
Created attachment 701705 [details]
Patch v1

This solve the problem

if (app.isBookmark) {
   app.uninstall();
} else {
   navigator.mozApps.mgmt.uninstall(app);
}
Attachment #701705 - Flags: review?(21)
(Reporter)

Comment 6

5 years ago
Are everything.me apps added to the homescreen also classified as bookmarks?

Just want to double check that the patch is taking bookmarks added to the homescreen and everything.me apps added to the homescreen into account.
(Assignee)

Comment 7

5 years ago
Yes, evme apps and web pages from browser are bookmarks
Duplicate of this bug: 830229
Thanks for catching this, where I was not aware of the bookmark deleting branch. So we don't need to consider doing the same thing for the settings app, because it can only uninstall a normal (non-bookmark) app. Right?
(Assignee)

Comment 10

5 years ago
You are right, Settings doesn't show bookmarks only apps
blocking-b2g: tef? → tef+

Updated

5 years ago
status-b2g18: --- → fixed
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
tracking-b2g18: ? → ---

Comment 13

5 years ago
Seems issue has been fixed. Does not repro anymore. 
Verified  on Unagi Build ID: 201302014070203
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia:   6544fdb8dddc56f1aefe94482402488c89eeec49
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.