Drag & drop links into toolkit downloads manager to download files fails (TypeError: aInitiatingDocument is undefined)

VERIFIED FIXED in Firefox 19

Status

()

Toolkit
Downloads API
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: jdm)

Tracking

({regression})

18 Branch
mozilla21
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox18- wontfix, firefox19+ verified, firefox20+ verified, firefox21+ verified, firefox-esr17 unaffected)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/releases/mozilla-beta/rev/222e6877be4b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0 ID:20130109111322

Drag & drop links into toolkit downloads manager(by defaultin 18beta and Aurora19) to download files.

This is regression by Bug 795065,


Steps to reproduce.
1. Open any page
2. Open Downloads (Tools > Downloads Ctrl+J)
3. Drag & drop links into the toolkit downloads manager

Actual results:
Allow to drop pointer appears, but cannot to save.

And the following error in Error console:

Error: TypeError: aInitiatingDocument is undefined
Source file: chrome://global/content/contentAreaUtils.js
Line: 340


Expected results:
Allowed to drop links and saved to folder.



Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/5ac283a12f02
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121003055717
Bad:
http://hg.mozilla.org/mozilla-central/rev/ae646840907e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121003184418
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5ac283a12f02&tochange=ae646840907e


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e9633e93b7e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121003093317
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/eff426a003e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121003101117
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e9633e93b7e2&tochange=eff426a003e1

Regressed by:
eff426a003e1	Josh Matthews — Bug 795065 - Add privacy status to nsDownload. r=mak sr=bz
(Reporter)

Comment 1

5 years ago
FYI, in Firefox18 and Firefox bata19, the toolkit downloads manager is default .

Comment 2

5 years ago
The STR here do not make the issue critical enough to fix in a dot release of FF18. Let's resolve for FF19.
Assignee: nobody → josh
status-firefox18: affected → wontfix
status-firefox19: --- → affected
status-firefox20: --- → affected
status-firefox21: --- → affected
tracking-firefox18: ? → -
tracking-firefox19: ? → +
tracking-firefox20: ? → +
tracking-firefox21: ? → +
(Assignee)

Comment 3

5 years ago
Created attachment 701772 [details] [diff] [review]
Use proper document for dropping links on toolkit download UI.
Attachment #701772 - Flags: review?(mak77)
Comment on attachment 701772 [details] [diff] [review]
Use proper document for dropping links on toolkit download UI.

Review of attachment 701772 [details] [diff] [review]:
-----------------------------------------------------------------

This is fine, though I found other saveURL() calls that don't properly set the document, especially
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/downloads/content/downloads.js#746
that is in the same file you are fixing here and has the same issue (6th argument instead of 7th).
r=me provided you fix both bugs in this file!

I also found this other call that may be fixed here or in a separate bug filed under Downloads Panel, as you prefer
http://mxr.mozilla.org/mozilla-central/source/browser/components/downloads/content/indicator.js#541
Attachment #701772 - Flags: review?(mak77) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3072e256623

I fixed the indicator bug as well.
(Assignee)

Comment 6

5 years ago
Created attachment 704535 [details] [diff] [review]
Use proper document for dropping links on toolkit download UI.
(Assignee)

Updated

5 years ago
Attachment #701772 - Attachment is obsolete: true
(Assignee)

Comment 7

5 years ago
Comment on attachment 704535 [details] [diff] [review]
Use proper document for dropping links on toolkit download UI.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 795065
User impact if declined: Broken functionality that worked in FF versions until 17.
Testing completed (on m-c, etc.): m-c.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #704535 - Flags: approval-mozilla-beta?
Attachment #704535 - Flags: approval-mozilla-aurora?

Comment 8

5 years ago
Comment on attachment 704535 [details] [diff] [review]
Use proper document for dropping links on toolkit download UI.

Approving for Aurora 20 and Beta 19. Please land as soon as possible today to make it into beta 3.
Attachment #704535 - Flags: approval-mozilla-beta?
Attachment #704535 - Flags: approval-mozilla-beta+
Attachment #704535 - Flags: approval-mozilla-aurora?
Attachment #704535 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/a2bc1943f3e0
https://hg.mozilla.org/releases/mozilla-beta/rev/a9c77e3dd141
status-firefox19: affected → fixed
status-firefox20: affected → fixed
status-firefox21: affected → fixed

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c3072e256623
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Verified as fixed on FF 19.0 b3
User agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130123083802
status-firefox19: fixed → verified
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed on Firefox 20.0 (buildID: 20130326150557).
status-firefox20: fixed → verified
Verified as fixed on Firefox 21 beta 2 (build ID: 20130401192816)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.