Seamonkey-aurora and trunk needs to have release-l10n created

RESOLVED FIXED in seamonkey2.18

Status

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

unspecified
seamonkey2.18
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

7 years ago
Both SeaMonkey Aurora and SeaMonkey trunk needs to have release-l10n 
created in suite/config/(linux32,linux64,macosx-universal,macosx64,win32)
so that the next time around when they are merged, they won't
break.
Assignee

Updated

7 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Assignee

Comment 1

7 years ago
Attachment #701676 - Flags: review?(bugspam.Callek)
Comment on attachment 701676 [details] [diff] [review]
Add release-l10n to aurora tree.

Review of attachment 701676 [details] [diff] [review]:
-----------------------------------------------------------------

r+a+ if you do as I describe :-) Please land the same resulting patch on central as well.

::: suite/config/mozconfigs/linux32/release-l10n
@@ +1,3 @@
> +if [ "$MOZ_UPDATE_CHANNEL" == "aurora" ]; then
> +  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> +fi;

don't add aurora here, this file is only used for releases, and we don't spin releases on aurora.

::: suite/config/mozconfigs/linux64/release-l10n
@@ +1,3 @@
> +if [ "$MOZ_UPDATE_CHANNEL" == "aurora" ]; then
> +  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> +fi;

nor here

::: suite/config/mozconfigs/macosx-universal/release-l10n
@@ +19,5 @@
> +fi
> +
> +if [ "$MOZ_UPDATE_CHANNEL" == "aurora" ]; then
> +  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> +fi;

here

::: suite/config/mozconfigs/macosx64/release-l10n
@@ +1,3 @@
> +if [ "$MOZ_UPDATE_CHANNEL" == "aurora" ]; then
> +  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> +fi;

here

::: suite/config/mozconfigs/win32/release-l10n
@@ +1,3 @@
> +if [ "$MOZ_UPDATE_CHANNEL" == "aurora" ]; then
> +  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> +fi;

and lastly here
Attachment #701676 - Flags: review?(bugspam.Callek)
Attachment #701676 - Flags: review+
Attachment #701676 - Flags: approval-comm-aurora+
Assignee

Comment 3

7 years ago
[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

aurora release builds will break without this patch.
Attachment #701676 - Attachment is obsolete: true
Attachment #708025 - Flags: review+
Attachment #708025 - Flags: approval-comm-aurora?
Assignee

Comment 6

7 years ago
Comment on attachment 708025 [details] [diff] [review]
Add release-l10n to aurora tree.(v2)

This patch was approved to aurora by Callek, but I couldn't forward + the approval.

Comment 8

7 years ago
Comment on attachment 708054 [details] [diff] [review]
Add release-l10n to trunk tree.

Forwarding a=comm-aurora/
Attachment #708054 - Flags: approval-comm-aurora+
Assignee

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Target Milestone: --- → seamonkey2.18
Attachment #708025 - Flags: approval-comm-aurora? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.