Closed Bug 830109 (SQLite3.7.15.2) Opened 7 years ago Closed 7 years ago

Upgrade to SQLite 3.7.15.2

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

()

Details

Attachments

(1 file)

SQLite Release 3.7.15.2 On 2013-01-09 (3.7.15.2)

* Fix a bug, introduced in version 3.7.15, that causes an ORDER BY clause to be optimized out of a three-way join when the ORDER BY is actually required. Ticket 598f5f7596b055
https://tbpl.mozilla.org/?tree=Try&rev=e0920965a277
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #701576 - Flags: review?(mak77)
Comment on attachment 701576 [details] [diff] [review]
Upgrade to SQLite 3.7.15.2 - Mozilla changes

Review of attachment 701576 [details] [diff] [review]:
-----------------------------------------------------------------

eww, this looks like may be hitting some of our queries, I think considered the size of the change would be really safer to uplift this version to aurora, please.
Attachment #701576 - Flags: review?(mak77) → review+
I will request approval once this lands on m-c. Thanks for the quick review!
https://hg.mozilla.org/mozilla-central/rev/bd5b952215e6
https://hg.mozilla.org/mozilla-central/rev/996cceda3ecd
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Comment on attachment 701576 [details] [diff] [review]
Upgrade to SQLite 3.7.15.2 - Mozilla changes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 824167
User impact if declined: Possible broken behavior
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): revert Aurora to prior release
String or UUID changes made by this patch: none
Attachment #701576 - Flags: approval-mozilla-aurora?
to explain the possibilities that made us ask for this approval, basically some queries, when optimized by SQLite, may drop the ORDER BY clause, thus returning results in an unexpected sorting order. While our tests are passing, it's safer to take this small fix since we don't have 100% coverage.
Comment on attachment 701576 [details] [diff] [review]
Upgrade to SQLite 3.7.15.2 - Mozilla changes

Very minor upgrade to SQLite. We're early in the Aurora cycle, so approving for uplift.
Attachment #701576 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: SQLite3.7.16
You need to log in before you can comment on or make changes to this bug.