Closed Bug 830131 Opened 7 years ago Closed 7 years ago

java.lang.NullPointerException: at org.mozilla.gecko.InputMethods.needsSoftResetWorkaround(InputMethods.java)

Categories

(Firefox for Android :: Keyboards and IME, defect, critical)

20 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: scoobidiver, Assigned: jchen)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

It first showed up in 21.0a1/20130113 and has been hit by three users. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1761f4a9081c&tochange=23eb44a5636b

Here is a crash report: bp-d83f959b-71ce-47e4-ba8c-6de3e2130113.

java.lang.NullPointerException
	at org.mozilla.gecko.InputMethods.needsSoftResetWorkaround(InputMethods.java:90)
	at org.mozilla.gecko.GeckoInputConnection.restartInput(GeckoInputConnection.java:224)
	at org.mozilla.gecko.GeckoInputConnection.notifyIMEEnabled(GeckoInputConnection.java:562)
	at org.mozilla.gecko.GeckoEditable$4.run(GeckoEditable.java:563)
	at android.os.Handler.handleCallback(Handler.java:725)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:5039)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.InputMethods.needsSoftResetWorkaround%28InputMethods.java%29
It's #3 top crasher in today's build.
tracking-fennec: --- → ?
Keywords: topcrash
Assignee: nobody → nchen
Blocks: 825120
Comment on attachment 701839 [details] [diff] [review]
Avoid null String comparison in InputMethods.java (v1)

Review of attachment 701839 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #701839 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3f595d0430b
Status: NEW → ASSIGNED
tracking-fennec: ? → ---
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/e3f595d0430b
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 701839 [details] [diff] [review]
Avoid null String comparison in InputMethods.java (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 825120

User impact if declined: Crash in certain situations

Testing completed (on m-c, etc.): Locally

Risk to taking this patch (and alternatives if risky): Very small; this is a fix for a null pointer regression from Bug 825120, and since Bug 825120 is being uplifted to Aurora, this should be uplifted too.

String or UUID changes made by this patch: None
Attachment #701839 - Flags: approval-mozilla-aurora?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I haven't seen crashes in 21.0a1/20130117. Why did you reopen it?
(In reply to Scoobidiver from comment #7)
> I haven't seen crashes in 21.0a1/20130117. Why did you reopen it?

Sorry. I wanted to keep track of bugs that I nominated for uplifting. I will close this once it's uplifted.
This is marked as unaffected in aurora (20) - and I'm not seeing it in crash stats for 20.  Can you confirm this needs to be uplifted?
Flags: needinfo?(nchen)
(In reply to Lukas Blakk [:lsblakk] from comment #9)
> This is marked as unaffected in aurora (20) - and I'm not seeing it in crash
> stats for 20.  Can you confirm this needs to be uplifted?

Yes, this is a regression from Bug 825120, which is approved for Aurora. Aurora will be affected once Bug 825120 lands on Aurora.

Sorry for the confusion!
Flags: needinfo?(nchen)
Attachment #701839 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/45b35a3a46c7
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Version: Firefox 21 → Firefox 20
You need to log in before you can comment on or make changes to this bug.