Secure camera doesn't work (& won't tell you why) when USB storage is mounted

VERIFIED FIXED

Status

Firefox OS
Gaia::Camera
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({b2g-testdriver, unagi})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
 0. Have a passcode lock enabled on your phone.
 1. Turn on USB storage in settings.
 2. Connect phone via USB. --> USB storage becomes mounted.
 3. Turn screen off & on, to get to lock screen.
 4. Slide up bar at the bottom, and tap Camera icon.

ACTUAL RESULTS: Secure Camera doesn't work -- screen is black (aside from camera buttons), and camera buttons are non-functional. (I can't even toggle between Video & Camera mode)

EXPECTED RESULTS: The same dialog that the normal Camera app displays, if I perform the STR but use the normal camera app -- "Camera Can Not Be Used While Plugged In | Unplug the phone to view pictures"
Build ID: 20130110070201
This is now working as expected. After camera has booted, a blocking overlay appears asking the user to unplug the device.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

4 years ago
Thanks! I can verify that Comment 1 is correct, with my original STR. Marking as VERIFIED.

(I filed bug 1004524 on what I think is a typo in the language on the overlay, FWIW.)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.