Closed Bug 830281 Opened 12 years ago Closed 12 years ago

Test failure "Not enough arguments [nsIWebBrowserPersist.saveURI]" in l10n//testAccessKeys/test1.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

defect

Tracking

(firefox18 fixed, firefox19 fixed, firefox20 fixed, firefox21 fixed, firefox-esr10 unaffected, firefox-esr17 unaffected)

RESOLVED FIXED
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed
firefox21 --- fixed
firefox-esr10 --- unaffected
firefox-esr17 --- unaffected

People

(Reporter: AndreeaMatei, Assigned: andrei)

References

()

Details

(Keywords: regression, Whiteboard: [mozmill-l10n][mozmill-test-failure] s=130121 u=failure c=l10n p=1)

Attachments

(1 file)

This happens on all sort of locales, for Aurora, across all platforms. 

accessKey: "a" found in: button#restoreDefaultHomePage, radio#alwaysAsk

The values for the accessKey are slightly different depending on the locale.

* http://mozmill-ci.blargon7.com/#/l10n/report/bddfde7ab90491e4945eb7577c3ea69c
* http://mozmill-ci.blargon7.com/#/l10n/report/bddfde7ab90491e4945eb7577c3e6251
Whiteboard: [mozmill-test-failure]
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-l10n] s=130114 u=failure c=l10n p=1
The initial description is fairly wrong and should refer to the failure as given in the summary. No accesskey failures will be handled here.
Also all branches should be affected. We simply don't see those failures because we only run the tests for aurora in CI.
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
Depends on: 831297
As discussed on IRC we will punt this bug in favor of getting bug 831297 fixed first.
Assignee: andrei.eftimie → nobody
Status: ASSIGNED → NEW
Whiteboard: [mozmill-test-failure][mozmill-l10n] s=130114 u=failure c=l10n p=1 → [mozmill-test-failure][mozmill-l10n] s=130121 u=failure c=l10n p=1
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
This was caused by bug 795065 and is a trivial fix. Whether esr17 nor esr10 are affected.
Blocks: 795065
Keywords: regression
Whiteboard: [mozmill-test-failure][mozmill-l10n] s=130121 u=failure c=l10n p=1 → [mozmill-l10n][mozmill-test-failure] s=130121 u=failure c=l10n p=1
Attached patch patch v1Splinter Review
Added a 7th param to the saveURI method call.
Attachment #708488 - Flags: review?(hskupin)
Attachment #708488 - Flags: review?(dave.hunt)
Attachment #708488 - Flags: review?(andreea.matei)
Comment on attachment 708488 [details] [diff] [review]
patch v1

Review of attachment 708488 [details] [diff] [review]:
-----------------------------------------------------------------

Wasn't sure about the needed value of that parameter, but after digging a bit, it's ok.
Attachment #708488 - Flags: review?(hskupin)
Attachment #708488 - Flags: review?(dave.hunt)
Attachment #708488 - Flags: review?(andreea.matei)
Attachment #708488 - Flags: review+
Keywords: checkin-needed
Comment on attachment 708488 [details] [diff] [review]
patch v1

Please make sure to add a better commit message in the feature so we know what's getting fixed.

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/a9c50dd3b5d5 (default)
Attachment #708488 - Flags: checkin+
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: